summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorslioch <slioch@eng-140.vyatta.com>2008-12-04 14:46:29 -0800
committerslioch <slioch@eng-140.vyatta.com>2008-12-04 14:46:29 -0800
commitc5c8f6916e7c96d61d9788b0ec54be38e379d4d5 (patch)
treee7c0f1c9ad82addd51b92af2acab563227aa1067
parent1c57ff025f86300db03dfa8fe08f7e64bf462629 (diff)
parent39e48d2c1b6dfea8b33abde538d2dd9739aa5d9d (diff)
downloadvyatta-wanloadbalance-c5c8f6916e7c96d61d9788b0ec54be38e379d4d5.tar.gz
vyatta-wanloadbalance-c5c8f6916e7c96d61d9788b0ec54be38e379d4d5.zip
Merge branch 'jenner' of http://git.vyatta.com/vyatta-wanloadbalance into jenner
-rw-r--r--debian/changelog60
-rw-r--r--scripts/vyatta-wanloadbalance.pl18
2 files changed, 69 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index b589816..19a14a6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,63 @@
+vyatta-wanloadbalance (0.13) unstable; urgency=low
+
+ 3.2.0
+ [ Mark O'Brien ]
+
+
+ [ slioch ]
+ * fix for bug 3608. add connnection comment to sudoers directory.
+ * fix for bug 3843. added warning level syslong messages on any
+ interface that changes state in wan lb.
+ * fix for bug 3817
+ * allow free form text field entry for inbound-interface. This allows
+ a wildcard (iptables style) interface to be set, allowing an
+ * missed this configuration node on checkin fix for bug 3332. Now
+ command is available.
+ * fix for bug 3710. also found and fixed another bug with restarting
+ of wlb after changing rule set. this simplifies the application of
+ the rules to
+
+ [ Mike Larson ]
+ * modified failover algorithm to provide deterministic control over
+ which interface is selected. The interface with the highest weight
+ will be preferred.
+ * add rule failover support. Failover mode can now be specified on a
+ specific rule. This rule will only direct traffic to a single active
+ interface, on failure of the ping target traffice will be directed
+ out an alternate interface.
+ * revised fix for dst-range bug to mirror fix for src.
+
+ [ slioch ]
+ * fix for bug 3621.
+
+ [ root ]
+ * fix for bug 3608.
+ * snat rules created by wanloadbanana are now applied before snat
+ rules created by nat. this shouldn't be a problem for nat, as the
+ wanloadbanana rules are filters on packets marked in the mangle
+ table.
+ * Partial fix for bug 3332. WLB can now be configured to run without
+ creating implicit source nat rules.
+ * fixed bug in parsing multiple rule sets
+ * fix for bug 3620. exclusion option is now provided and will create
+ an accept rule. For an exclusion the user does not need to configure
+ interfaces for that rule to balance across.
+ * fix for bug 3530. now nexthop and inbound-interface are required for
+ a successful commit.
+ * added new command that dumps the ip conntrack tables for connections
+ that have been marked by wan load balance. This addresses
+ enhancement request bug 3191.
+
+ [ Stephen Hemminger ]
+ * Handle quagga package name change
+
+ [ root ]
+ * fix for bug 3446. protocol assignment is now identical to firewall.
+
+ [ Mark O'Brien ]
+
+ -- Mark O'Brien <mobrien@firebolt.vyatta.com> Tue, 25 Nov 2008 19:11:06 -0800
+
vyatta-wanloadbalance (0.12) unstable; urgency=low
3.1.2
diff --git a/scripts/vyatta-wanloadbalance.pl b/scripts/vyatta-wanloadbalance.pl
index 49cb05b..56d4bc4 100644
--- a/scripts/vyatta-wanloadbalance.pl
+++ b/scripts/vyatta-wanloadbalance.pl
@@ -9,9 +9,9 @@
# **** End License ****
#
use lib "/opt/vyatta/share/perl5/";
-use VyattaConfig;
-use VyattaMisc;
-use VyattaTypeChecker;
+use Vyatta::Config;
+use Vyatta::Misc;
+use Vyatta::TypeChecker;
use warnings;
use strict;
@@ -20,7 +20,7 @@ use File::Copy;
sub write_health {
#open conf
- my $config = new VyattaConfig;
+ my $config = new Vyatta::Config;
my $valid = "false";
@@ -78,7 +78,7 @@ sub write_health {
}
sub write_rules {
- my $config = new VyattaConfig;
+ my $config = new Vyatta::Config;
my $valid = "false";
@@ -117,7 +117,7 @@ sub write_rules {
print FILE_LCK "\tdestination {\n";
my $daddr = $config->returnValue("$rule destination address");
if (defined $daddr) {
- if (VyattaTypeChecker::validate_iptables4_addr($daddr) eq "1") {
+ if (Vyatta::TypeChecker::validate_iptables4_addr($daddr) eq "1") {
print FILE_LCK "\t\taddress \"" . $daddr . "\"\n";
}
else {
@@ -135,7 +135,7 @@ sub write_rules {
if ($protocol eq "tcp" || $protocol eq "udp") {
$can_use_port = "yes";
}
- ($port_str, $port_err) = VyattaMisc::getPortRuleString($option, $can_use_port, "d", $protocol);
+ ($port_str, $port_err) = Vyatta::Misc::getPortRuleString($option, $can_use_port, "d", $protocol);
if (defined $port_str) {
print FILE_LCK "\t\tport-ipt \"" . $port_str . "\"\n";
}
@@ -154,7 +154,7 @@ sub write_rules {
print FILE_LCK "\tsource {\n";
my $saddr = $config->returnValue("$rule source address");
if (defined $saddr) {
- if (VyattaTypeChecker::validate_iptables4_addr($saddr) eq "1") {
+ if (Vyatta::TypeChecker::validate_iptables4_addr($saddr) eq "1") {
print FILE_LCK "\t\taddress \"" . $saddr . "\"\n";
}
else {
@@ -172,7 +172,7 @@ sub write_rules {
if ($protocol eq "tcp" || $protocol eq "udp") {
$can_use_port = "yes";
}
- ($port_str, $port_err) = VyattaMisc::getPortRuleString($option, $can_use_port, "d", $protocol);
+ ($port_str, $port_err) = Vyatta::Misc::getPortRuleString($option, $can_use_port, "d", $protocol);
if (defined $port_str) {
print FILE_LCK "\t\tport-ipt \"" . $port_str . "\"\n";
}