summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAn-Cheng Huang <ancheng@vyatta.com>2010-08-27 17:34:39 -0700
committerAn-Cheng Huang <ancheng@vyatta.com>2010-08-27 17:34:39 -0700
commit2b52975cacf817d2b3058a94c7386cacf50b47c2 (patch)
tree7eb7601ac674a3fcaa02d1c10d731b63f8b965c1
parentfbeb26889575ee0a073bfc35bf7d29886e35d0da (diff)
downloadvyatta-wanloadbalance-2b52975cacf817d2b3058a94c7386cacf50b47c2.tar.gz
vyatta-wanloadbalance-2b52975cacf817d2b3058a94c7386cacf50b47c2.zip
fix squeeze build issues
-rw-r--r--.gitignore1
-rw-r--r--configure.ac1
-rw-r--r--src/lbdata.cc1
-rw-r--r--src/lbdatafactory.cc1
-rw-r--r--src/lbdecision.cc1
-rw-r--r--src/lboutput.cc1
-rw-r--r--src/lbtest.cc1
-rw-r--r--src/rl_str_proc.cc10
8 files changed, 11 insertions, 6 deletions
diff --git a/.gitignore b/.gitignore
index 773d039..5d6b644 100644
--- a/.gitignore
+++ b/.gitignore
@@ -24,6 +24,7 @@ libtool
/debian/vyatta-wanloadbalance.postrm
/debian/vyatta-wanloadbalance
/debian/vyatta-wanloadbalance.debhelper.log
+/debian/vyatta-wanloadbalance.substvars
/INSTALL
/Makefile.in
/Makefile
diff --git a/configure.ac b/configure.ac
index 38b00d0..956119d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,6 +16,7 @@ AM_INIT_AUTOMAKE([gnu no-dist-gzip dist-bzip2 subdir-objects])
AC_PREFIX_DEFAULT([/opt/vyatta])
AC_PROG_CC
+AC_PROG_CXX
AM_PROG_AS
AM_PROG_CC_C_O
AC_PROG_LIBTOOL
diff --git a/src/lbdata.cc b/src/lbdata.cc
index f454f09..4b0978e 100644
--- a/src/lbdata.cc
+++ b/src/lbdata.cc
@@ -5,6 +5,7 @@
* under the terms of the GNU General Public License version 2 as published
* by the Free Software Foundation.
*/
+#include <stdio.h>
#include <sys/time.h>
#include <syslog.h>
#include <sys/time.h>
diff --git a/src/lbdatafactory.cc b/src/lbdatafactory.cc
index 1fe2815..5336a79 100644
--- a/src/lbdatafactory.cc
+++ b/src/lbdatafactory.cc
@@ -5,6 +5,7 @@
* under the terms of the GNU General Public License version 2 as published
* by the Free Software Foundation.
*/
+#include <stdio.h>
#include <syslog.h>
#include <sys/socket.h>
#include <netinet/in.h>
diff --git a/src/lbdecision.cc b/src/lbdecision.cc
index 288a0ca..468b766 100644
--- a/src/lbdecision.cc
+++ b/src/lbdecision.cc
@@ -5,6 +5,7 @@
* under the terms of the GNU General Public License version 2 as published
* by the Free Software Foundation.
*/
+#include <stdio.h>
#include <sys/sysinfo.h>
#include <sys/socket.h>
#include <netinet/in.h>
diff --git a/src/lboutput.cc b/src/lboutput.cc
index 520dd6b..a3d1c6a 100644
--- a/src/lboutput.cc
+++ b/src/lboutput.cc
@@ -5,6 +5,7 @@
* under the terms of the GNU General Public License version 2 as published
* by the Free Software Foundation.
*/
+#include <stdio.h>
#include <sys/time.h>
#include <time.h>
#include <syslog.h>
diff --git a/src/lbtest.cc b/src/lbtest.cc
index a45d48f..f907c19 100644
--- a/src/lbtest.cc
+++ b/src/lbtest.cc
@@ -6,6 +6,7 @@
* by the Free Software Foundation.
*/
+#include <stdio.h>
#include <sys/time.h>
#include <syslog.h>
#include <sys/time.h>
diff --git a/src/rl_str_proc.cc b/src/rl_str_proc.cc
index 317efab..700c6c5 100644
--- a/src/rl_str_proc.cc
+++ b/src/rl_str_proc.cc
@@ -49,8 +49,7 @@ StrProc::StrProc(const string &in_str, const string &token)
string
StrProc::get(int i)
{
- /* uint32_t probably ok here */
- if (uint32_t(i) >= _str_coll.size()) {
+ if (size_t(i) >= _str_coll.size()) {
return string("");
}
return _str_coll[i];
@@ -62,14 +61,13 @@ StrProc::get(int i)
string
StrProc::get(int start, int end)
{
- /* uint32_t probably ok here */
- if (uint32_t(start) >= _str_coll.size()) {
+ if (size_t(start) >= _str_coll.size()) {
return string("");
}
string tmp;
- /* uint32_t probably ok here */
- for (int i = start; (i < end) && (uint32_t(i) < _str_coll.size()); ++i) {
+ for (size_t i = (size_t) start;
+ (i < end) && (i < _str_coll.size()); ++i) {
tmp += _str_coll[i] + " ";
}
return tmp.substr(0,tmp.length()-1);