summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Larson <mike@vyatta.com>2011-02-11 17:38:23 -0800
committerMichael Larson <mike@vyatta.com>2011-02-11 17:38:23 -0800
commit1c97581618cab567c9bc3ce230f1ee6fe63eaadb (patch)
tree24099b2f4ac5b859f1244aa63ef52a0f17f534f1
parentce3889d2cb214941eac4e21c768f70feacb64c04 (diff)
downloadvyatta-wanloadbalance-1c97581618cab567c9bc3ce230f1ee6fe63eaadb.tar.gz
vyatta-wanloadbalance-1c97581618cab567c9bc3ce230f1ee6fe63eaadb.zip
fix for 6711. Changed configuration node as requested by support.
-rw-r--r--Makefile.am2
-rw-r--r--cfg-version/wanloadbalance@3 (renamed from cfg-version/wanloadbalance@2)0
-rw-r--r--scripts/vyatta-wanloadbalance.pl4
-rw-r--r--src/lbdatafactory.cc2
-rw-r--r--templates/load-balancing/wan/rule/node.tag/enable-source-based-routing/node.def1
-rw-r--r--templates/load-balancing/wan/rule/node.tag/per-packet-balancing/node.def1
6 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 9cc2101..df689a4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,7 +22,7 @@ bin_sudo_users_SCRIPTS += scripts/vyatta-wlb-connection.pl
dhcphook_SCRIPTS = scripts/dhcp/dhcp-wanlb
ppphook_SCRIPTS = scripts/ppp/ppp-wanlb
-curver_DATA = cfg-version/wanloadbalance@2
+curver_DATA = cfg-version/wanloadbalance@3
src_wan_lb_SOURCES = src/main.cc
src_wan_lb_SOURCES += src/lbdata.cc
diff --git a/cfg-version/wanloadbalance@2 b/cfg-version/wanloadbalance@3
index e69de29..e69de29 100644
--- a/cfg-version/wanloadbalance@2
+++ b/cfg-version/wanloadbalance@3
diff --git a/scripts/vyatta-wanloadbalance.pl b/scripts/vyatta-wanloadbalance.pl
index 44dd865..354c59c 100644
--- a/scripts/vyatta-wanloadbalance.pl
+++ b/scripts/vyatta-wanloadbalance.pl
@@ -137,8 +137,8 @@ sub write_rules {
print FILE_LCK "\tfailover\n";
}
- if ($config->exists("$rule enable-source-based-routing")) {
- print FILE_LCK "\tenable-source-based-routing\n";
+ if ($config->exists("$rule per-packet-balancing")) {
+ print FILE_LCK "\tper-packet-balancing\n";
}
if ($config->exists("$rule failover") && $config->exists("$rule exclude")) {
diff --git a/src/lbdatafactory.cc b/src/lbdatafactory.cc
index 5336a79..9c5edc6 100644
--- a/src/lbdatafactory.cc
+++ b/src/lbdatafactory.cc
@@ -196,7 +196,7 @@ LBDataFactory::process(const vector<string> &path, int depth, const string &key,
else if (depth > 0 && path[1] == "failover") {
process_rule_failover(l_key,l_value);
}
- else if (depth > 0 && path[1] == "enable-source-based-routing") {
+ else if (depth > 0 && path[1] == "per-packet-balancing") {
process_rule_enablesourcebasedrouting(l_key,l_value);
}
else if (depth > 1 && path[1] == "limit") {
diff --git a/templates/load-balancing/wan/rule/node.tag/enable-source-based-routing/node.def b/templates/load-balancing/wan/rule/node.tag/enable-source-based-routing/node.def
deleted file mode 100644
index ed2e68c..0000000
--- a/templates/load-balancing/wan/rule/node.tag/enable-source-based-routing/node.def
+++ /dev/null
@@ -1 +0,0 @@
-help: Enable sourced based routing for wan load balancing
diff --git a/templates/load-balancing/wan/rule/node.tag/per-packet-balancing/node.def b/templates/load-balancing/wan/rule/node.tag/per-packet-balancing/node.def
new file mode 100644
index 0000000..aaacdcb
--- /dev/null
+++ b/templates/load-balancing/wan/rule/node.tag/per-packet-balancing/node.def
@@ -0,0 +1 @@
+help: Option to match traffic per-packet instead of the default, per-flow