summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMohit Mehta <mohit.mehta@vyatta.com>2010-10-07 18:07:16 -0700
committerMohit Mehta <mohit.mehta@vyatta.com>2010-10-07 18:07:16 -0700
commit1f7bba17f9d53aad7810718ea26d8bbad405b309 (patch)
tree5b3cef11c97d0bf39e51da049c1f8a21bdbe1cfc /debian
downloadvyatta-zone-1f7bba17f9d53aad7810718ea26d8bbad405b309.tar.gz
vyatta-zone-1f7bba17f9d53aad7810718ea26d8bbad405b309.zip
Initial releasedebian/0.1
Diffstat (limited to 'debian')
-rw-r--r--debian/README7
-rwxr-xr-xdebian/autogen.sh11
-rw-r--r--debian/compat1
-rw-r--r--debian/control20
-rw-r--r--debian/copyright15
-rw-r--r--debian/docs2
-rw-r--r--debian/lintian2
-rwxr-xr-xdebian/rules105
8 files changed, 163 insertions, 0 deletions
diff --git a/debian/README b/debian/README
new file mode 100644
index 0000000..fcac669
--- /dev/null
+++ b/debian/README
@@ -0,0 +1,7 @@
+The Debian Package vyatta-zone
+------------------------------
+
+This package contains the vyatta zone-policy project developed by vyatta. This
+package includes the programs, plus cli operational and commands.
+
+ -- Mohit Mehta <mohit@vyatta.com> Thu, 07 Oct 2010
diff --git a/debian/autogen.sh b/debian/autogen.sh
new file mode 100755
index 0000000..adb6d1c
--- /dev/null
+++ b/debian/autogen.sh
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+
+rm -rf config
+rm -f aclocal.m4 config.guess config.status config.sub configure INSTALL
+
+autoreconf --force --install
+
+rm -f config.sub config.guess
+ln -s /usr/share/misc/config.sub .
+ln -s /usr/share/misc/config.guess .
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..95ca4b5
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,20 @@
+Source: vyatta-zone
+Section: contrib/net
+Priority: extra
+Maintainer: Vyatta Package Maintainers <maintainers@vyatta.com>
+Build-Depends: debhelper (>= 5),
+ autotools-dev,
+Standards-Version: 3.7.2
+
+Package: vyatta-zone
+Architecture: all
+Depends: perl (>= 5.8.8),
+ vyatta-bash | bash (>= 3.1),
+ vyatta-cfg,
+ vyatta-cfg-firewall,
+ vyatta-idp-snort
+Replaces: vyatta-cfg,
+ vyatta-cfg-system
+Description: The vyatta-zone package
+ This package has the vyatta zone-policy programs, and
+ configuration/operational templates and scripts.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..e76762e
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,15 @@
+This package was debianized by Mohit Mehta <mohit@vyatta.com> on
+Thu Oct 7 15:06:32 PDT 2010
+
+It's original content from the GIT repository
+<http://git.vyatta.com/git/vyatta-zone>
+
+Upstream Author:
+
+ <eng@vyatta.com>
+
+Copyright:
+
+ Copyright (C) 2010 Vyatta, Inc.
+ All Rights Reserved.
+
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..50bd824
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1,2 @@
+NEWS
+README
diff --git a/debian/lintian b/debian/lintian
new file mode 100644
index 0000000..c9b27f0
--- /dev/null
+++ b/debian/lintian
@@ -0,0 +1,2 @@
+vyatta-zone: file-in-unusual-dir
+vyatta-zone: dir-or-file-in-opt
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f43d6fc
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,105 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+export DEB_BUILD_HARDENING=1
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+PACKAGE=vyatta-zone
+PKGDIR=$(CURDIR)/debian/$(PACKAGE)
+
+CFLAGS = -Wall -g
+
+configure = ./configure
+configure += --host=$(DEB_HOST_GNU_TYPE)
+configure += --build=$(DEB_BUILD_GNU_TYPE)
+configure += --prefix=/opt/vyatta
+configure += --mandir=\$${prefix}/share/man
+configure += --infodir=\$${prefix}/share/info
+configure += CFLAGS="$(CFLAGS)"
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+configure: configure.ac Makefile.am
+ chmod +x debian/autogen.sh
+ debian/autogen.sh
+
+config.status: configure
+ dh_testdir
+ rm -f config.cache
+ $(configure)
+
+build: build-stamp
+
+build-stamp: config.status
+ dh_testdir
+ $(MAKE)
+ touch $@
+
+clean: clean-patched
+
+# Clean everything up, including everything auto-generated
+# at build time that needs not to be kept around in the Debian diff
+clean-patched:
+ dh_testdir
+ dh_testroot
+ if test -f Makefile ; then $(MAKE) clean distclean ; fi
+ rm -f build-stamp
+ rm -f config.status config.sub config.guess config.log
+ rm -f aclocal.m4 configure Makefile.in Makefile INSTALL
+ rm -rf config
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ $(MAKE) DESTDIR=$(PKGDIR) install
+
+ install -D --mode=0644 debian/lintian $(PKGDIR)/usr/share/lintian/overrides/$(PACKAGE)
+
+# Build architecture-independent files here.
+binary-indep: build install
+ rm -f debian/files
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs ChangeLog
+ dh_installdocs
+ dh_install
+ dh_installdebconf
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ if [ -f "../.VYATTA_DEV_BUILD" ]; then \
+ dh_gencontrol -- -v999.dev; \
+ else \
+ dh_gencontrol; \
+ fi
+ dh_md5sums
+ dh_builddeb
+
+# Build architecture-dependent files here.
+binary-arch: build install
+# This is an architecture independent package
+# so; we have nothing to do by default.
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install