summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorThomas Mangin <thomas.mangin@exa.net.uk>2020-06-22 21:04:20 +0100
committerThomas Mangin <thomas.mangin@exa.net.uk>2020-06-22 21:04:20 +0100
commit88ede50d106c8cea494aacdcd346911b1058ffd1 (patch)
treea3fbe5d5010e3d7329e437de0b785d6c136e8c9b /debian/rules
parent7e258d0f77c005baf27a50160aa8b82b8562975c (diff)
downloadvyos-1x-88ede50d106c8cea494aacdcd346911b1058ffd1.tar.gz
vyos-1x-88ede50d106c8cea494aacdcd346911b1058ffd1.zip
xml: T2588: code to extract defaults values from xml
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 3e408b538..c080b8633 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,6 +23,10 @@ override_dh_auto_build:
override_dh_auto_install:
dh_auto_install
+
+ # convert the XML to dictionaries
+ env PYTHONPATH=python python3 python/vyos/xml/generate.py
+
cd python; python3 setup.py install --install-layout=deb --root ../$(DIR); cd ..
# Install scripts