summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2019-02-24 21:04:35 +0100
committerChristian Poessinger <christian@poessinger.com>2019-02-24 21:09:04 +0100
commit735a24d58ddf55294241ce8160471fe9be062498 (patch)
treeb8999f32cf79f60a2374301c579f74a2c7bb89b6 /debian/rules
parentbb874fe0aff6f5a21b489a01d84fa16cfe48c69a (diff)
downloadvyos-1x-735a24d58ddf55294241ce8160471fe9be062498.tar.gz
vyos-1x-735a24d58ddf55294241ce8160471fe9be062498.zip
[tftp] T1261: bugfix listening on multiple IP addesses
tftp-hpa which is the TFTP daemon used by VyOS does not support listening on multiple IP adresses. With this limitation we will start one TFTP daemon instance per configured listen-address via systemd.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 663aff4d9..a24d0280a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -68,3 +68,7 @@ override_dh_auto_install:
# Install etc configuration files
mkdir -p $(DIR)/etc
cp -r src/etc/* $(DIR)/etc
+
+ # Install systemd service units
+ mkdir -p $(DIR)/lib/systemd/system
+ cp -r src/systemd/* $(DIR)/lib/systemd/system