summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJohn Estabrook <jestabro@vyos.io>2021-09-30 12:56:22 -0500
committerGitHub <noreply@github.com>2021-09-30 12:56:22 -0500
commitee5af5ddc65333c76baa498d6131f69073e39a7e (patch)
treee755f3e982c8fd33fd50b2778da8e082169504cf /debian/rules
parent17dc7cd0aaca5c4ae14d3dc843de7a5b612ab5ed (diff)
parentbfc5d6a1a48578a47369bde40388ec02bcedfa33 (diff)
downloadvyos-1x-ee5af5ddc65333c76baa498d6131f69073e39a7e.tar.gz
vyos-1x-ee5af5ddc65333c76baa498d6131f69073e39a7e.zip
Merge pull request #1019 from jestabro/interface-names
T3869: Rewrite vyatta_net_name/vyatta_interface_rescan in Python
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c7a7138e1..5a58aeeb6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -120,6 +120,10 @@ override_dh_auto_install:
mkdir -p $(DIR)/$(VYOS_BIN_DIR)
cp -r smoketest/bin/* $(DIR)/$(VYOS_BIN_DIR)
+ # Install udev script
+ mkdir -p $(DIR)/usr/lib/udev
+ cp src/helpers/vyos_net_name $(DIR)/usr/lib/udev
+
ifeq ($(DEB_TARGET_ARCH),amd64)
# We only install XDP on amd64 systems
mkdir -p $(DIR)/$(VYOS_DATA_DIR)/xdp