summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniil Baturin <daniil@baturin.org>2018-05-29 23:07:52 +0200
committerDaniil Baturin <daniil@baturin.org>2018-05-29 23:07:52 +0200
commit737d72dc07e630231202fe1ae513c6195b6d250b (patch)
tree057ced5d09ae9567c889ee8bdea442e028467cf0 /debian/rules
parenta331911473ddf3d9313a45a9cf126a4d1ead4753 (diff)
downloadvyos-1x-737d72dc07e630231202fe1ae513c6195b6d250b.tar.gz
vyos-1x-737d72dc07e630231202fe1ae513c6195b6d250b.zip
T667: add a migration script for converting "system gateway-address" to "protocols static route 0.0.0.0".
Code-wise that option was in vyatta-cfg-quagga, but the syntax is inside "system", so let's keep the script under system too.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 8 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 31deefeff..749b0d46b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,6 +7,8 @@ VYOS_LIBEXEC_DIR := usr/libexec/vyos
VYOS_CFG_TMPL_DIR := /opt/vyatta/share/vyatta-cfg/templates
VYOS_OP_TMPL_DIR := /opt/vyatta/share/vyatta-op/templates
+MIGRATION_SCRIPTS_DIR := /opt/vyatta/etc/config-migrate/migrate/
+
%:
dh $@ --with python3, --with quilt
@@ -40,8 +42,14 @@ override_dh_auto_install:
# Install helper scripts
cp -r src/helpers/* $(DIR)/$(VYOS_LIBEXEC_DIR)/
+ # Install migration scripts
+ mkdir -p $(DIR)/$(MIGRATION_SCRIPTS_DIR)
+ cp -r src/migration-scripts/* $(DIR)/$(MIGRATION_SCRIPTS_DIR)
+
+ # Install configuration command definitions
mkdir -p $(DIR)/$(VYOS_CFG_TMPL_DIR)
cp -r templates-cfg/* $(DIR)/$(VYOS_CFG_TMPL_DIR)
+ # Install operational command definitions
mkdir -p $(DIR)/$(VYOS_OP_TMPL_DIR)
cp -r templates-op/* $(DIR)/$(VYOS_OP_TMPL_DIR)