summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2019-12-28 09:43:50 +0100
committerChristian Poessinger <christian@poessinger.com>2019-12-28 09:43:50 +0100
commitae2c359c2938466001359823d4b2a97bd360a889 (patch)
tree9e5027ef4500bfa79e776743ee8a13cccf0eb3ce /debian/rules
parent4f42b4f7411dd4ca4e670a47be1dfe7f81d02e05 (diff)
downloadvyos-1x-ae2c359c2938466001359823d4b2a97bd360a889.tar.gz
vyos-1x-ae2c359c2938466001359823d4b2a97bd360a889.zip
Debian: install binary to /usr/bin
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 2 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 4ccc23e86..526fb8537 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,6 @@
#!/usr/bin/make -f
DIR := debian/vyos-smoketest
-VYOS_SBIN_DIR := usr/sbin/
VYOS_BIN_DIR := usr/bin/
VYOS_LIBEXEC_DIR := usr/libexec/vyos
VYOS_DATA_DIR := /usr/share/vyos
@@ -10,8 +9,6 @@ VYOS_OP_TMPL_DIR := /opt/vyatta/share/vyatta-op/templates
MIGRATION_SCRIPTS_DIR := /opt/vyatta/etc/config-migrate/migrate/
-SBINDIR := $(DIR)/usr/sbin
-
%:
dh $@ --with python3, --with quilt
@@ -24,5 +21,5 @@ override_dh_auto_install:
cp -r scripts/* $(DIR)/$(VYOS_LIBEXEC_DIR)/tests/smoke
# Install system programs
- mkdir -p $(SBINDIR)
- cp -r bin/* $(SBINDIR)
+ mkdir -p $(DIR)/$(VYOS_BIN_DIR)
+ cp -r bin/* $(DIR)/$(VYOS_BIN_DIR)