summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2021-06-22 18:34:21 +0200
committerChristian Poessinger <christian@poessinger.com>2021-06-22 18:34:58 +0200
commit47604c76587cc6cb7742e91940de2f40ad6d7eb0 (patch)
tree719d4d06886b6c4855e3940781778a33ca4f19d3 /debian/rules
parentdebd7996f89b01fa8d3584efbcda9a5675ee4344 (diff)
downloadvyos-1x-47604c76587cc6cb7742e91940de2f40ad6d7eb0.tar.gz
vyos-1x-47604c76587cc6cb7742e91940de2f40ad6d7eb0.zip
snmp: T3606: Install MIBs into well known location
FRR also expects the MIBs in /usr/share/snmp/mibs
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 5 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 8e5aee3e6..70d39c481 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,6 +7,7 @@ VYOS_LIBEXEC_DIR := usr/libexec/vyos
VYOS_DATA_DIR := usr/share/vyos
VYOS_CFG_TMPL_DIR := opt/vyatta/share/vyatta-cfg/templates
VYOS_OP_TMPL_DIR := opt/vyatta/share/vyatta-op/templates
+VYOS_MIBS_DIR := usr/share/snmp/mibs
MIGRATION_SCRIPTS_DIR := opt/vyatta/etc/config-migrate/migrate
SYSTEM_SCRIPTS_DIR := usr/libexec/vyos/system
@@ -84,6 +85,10 @@ override_dh_auto_install:
mkdir -p $(DIR)/$(VYOS_DATA_DIR)
cp -r data/* $(DIR)/$(VYOS_DATA_DIR)
+ # Install SNMP MIBs
+ mkdir -p $(DIR)/$(VYOS_MIBS_DIR)
+ cp -d mibs/* $(DIR)/$(VYOS_MIBS_DIR)
+
# Install etc configuration files
mkdir -p $(DIR)/etc
cp -r src/etc/* $(DIR)/etc