summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJohn Estabrook <jestabro@vyos.io>2024-10-24 10:50:34 -0500
committerJohn Estabrook <jestabro@vyos.io>2024-12-10 14:01:22 -0600
commitbab186b493145ee42453196e8ef4670afc71f6f1 (patch)
treea0d980d96c755f95bdc7c379535ebbdc9fd2b9b1 /debian/rules
parent0c4d653fc2db57df294856c2c77fe89d6f5923b8 (diff)
downloadvyos-1x-bab186b493145ee42453196e8ef4670afc71f6f1.tar.gz
vyos-1x-bab186b493145ee42453196e8ef4670afc71f6f1.zip
vyconf: T6718: add reftree internal cache
As we are generating the reference tree from the XML definitions during build, save an internal representation for vyconfd to load on startup.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index df1d9e7f3..c15fcab11 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,6 +9,7 @@ VYOS_CFG_TMPL_DIR := opt/vyatta/share/vyatta-cfg/templates
VYOS_OP_TMPL_DIR := opt/vyatta/share/vyatta-op/templates
VYOS_MIBS_DIR := usr/share/snmp/mibs
VYOS_LOCALUI_DIR := srv/localui
+VYCONF_CONFIG_DIR := $(VYOS_LIBEXEC_DIR)/vyconf/config
MIGRATION_SCRIPTS_DIR := opt/vyatta/etc/config-migrate/migrate
ACTIVATION_SCRIPTS_DIR := usr/libexec/vyos/activate
@@ -89,6 +90,8 @@ override_dh_auto_install:
cp -r templates-op/* $(DIR)/$(VYOS_OP_TMPL_DIR)
# Install data files
+ mkdir -p $(DIR)/$(VYCONF_CONFIG_DIR)
+ cp -r data/reftree.cache $(DIR)/$(VYCONF_CONFIG_DIR)
mkdir -p $(DIR)/$(VYOS_DATA_DIR)
cp -r data/* $(DIR)/$(VYOS_DATA_DIR)