summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2020-12-28 20:07:52 +0100
committerGitHub <noreply@github.com>2020-12-28 20:07:52 +0100
commit829e76f7392e348ccc01c56e9680efb4eba80440 (patch)
tree282dac56ecfccf381fa92ad9027df6779d16ae2f /debian
parentc1fcbba9cb45f981e5bd8decf3ebbc1e17d9fbd9 (diff)
parenteeb78e842423319169b036d16601e73227dbffdd (diff)
downloadvyos-1x-829e76f7392e348ccc01c56e9680efb4eba80440.tar.gz
vyos-1x-829e76f7392e348ccc01c56e9680efb4eba80440.zip
Merge pull request #643 from c-po/t563-webproxy
webproxy: T563: migrate from old Perl code to XML and get_config_dict()
Diffstat (limited to 'debian')
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/vyos-1x.install1
-rw-r--r--debian/vyos-1x.postinst3
4 files changed, 12 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index dc5094e8e..9750f08e2 100644
--- a/debian/control
+++ b/debian/control
@@ -99,6 +99,7 @@ Depends:
python3-pyudev,
python3-six,
python3-tabulate,
+ python3-tqdm,
python3-vici (>= 5.7.2),
python3-voluptuous,
python3-waitress,
@@ -108,6 +109,9 @@ Depends:
salt-minion,
snmp,
snmpd,
+ squid,
+ squidclient,
+ squidguard,
ssl-cert,
systemd,
tcpdump,
diff --git a/debian/rules b/debian/rules
index ab0df7201..5e275b8a3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -51,6 +51,10 @@ override_dh_auto_install:
mkdir -p $(DIR)/$(VYOS_LIBEXEC_DIR)/completion
cp -r src/completion/* $(DIR)/$(VYOS_LIBEXEC_DIR)/completion
+ # Install legacy components
+ mkdir -p $(DIR)/$(VYOS_LIBEXEC_DIR)/legacy
+ cp -r src/legacy/* $(DIR)/$(VYOS_LIBEXEC_DIR)/legacy
+
# Install helper scripts
cp -r src/helpers/* $(DIR)/$(VYOS_LIBEXEC_DIR)/
diff --git a/debian/vyos-1x.install b/debian/vyos-1x.install
index bfc30f7e6..691fa4731 100644
--- a/debian/vyos-1x.install
+++ b/debian/vyos-1x.install
@@ -21,5 +21,6 @@ usr/libexec/vyos/op_mode
usr/libexec/vyos/services
usr/libexec/vyos/system
usr/libexec/vyos/validators
+usr/libexec/vyos/legacy
usr/libexec/vyos/*.py
usr/share
diff --git a/debian/vyos-1x.postinst b/debian/vyos-1x.postinst
index dc129cb54..92948de12 100644
--- a/debian/vyos-1x.postinst
+++ b/debian/vyos-1x.postinst
@@ -30,3 +30,6 @@ if ! grep -q '^dhcpd' /etc/passwd; then
adduser --quiet --system --disabled-login --no-create-home --home /run/dhcp-server dhcpd
adduser --quiet dhcpd hostsd
fi
+
+# ensure hte proxy user has a proper shell
+chsh -s /bin/sh proxy