summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2021-08-20 19:07:57 +0200
committerChristian Poessinger <christian@poessinger.com>2021-08-21 08:52:43 +0200
commit9fa00d537c5d7d0a5109907bba7d1825ef245ed1 (patch)
tree258ae0377e2edad97fbeb8cb3e68261ac9d97a96 /debian
parent1a498915efdc433dda7bd6e5fcc08703a48560c6 (diff)
downloadvyos-1x-9fa00d537c5d7d0a5109907bba7d1825ef245ed1.tar.gz
vyos-1x-9fa00d537c5d7d0a5109907bba7d1825ef245ed1.zip
Debian: disable time consuming dh_strip_nondeterminism
Skip dh_strip_nondeterminism - this is very time consuming and we have no non deterministic output (yet).
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 70d39c481..c7a7138e1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,6 +18,10 @@ DEB_TARGET_ARCH := $(shell dpkg-architecture -qDEB_TARGET_ARCH)
%:
dh $@ --with python3, --with quilt
+# Skip dh_strip_nondeterminism - this is very time consuming
+# and we have no non deterministic output (yet)
+override_dh_strip_nondeterminism:
+
override_dh_gencontrol:
dh_gencontrol -- -v$(shell (git describe --tags --long --match 'vyos/*' --dirty 2>/dev/null || echo 0.0-no.git.tag) | sed -E 's%vyos/%%' | sed -E 's%-dirty%+dirty%')