summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2020-06-22 22:08:20 +0200
committerChristian Poessinger <christian@poessinger.com>2020-06-22 22:08:20 +0200
commitbfa969c37711dbda98d407b66600fa789cadc8e1 (patch)
treeac6e510f07add0dd54d48cfcb95328113a74183b /debian
parente18fe3704a40ef25dfc3e248ae9f83aa053ef174 (diff)
parent88ede50d106c8cea494aacdcd346911b1058ffd1 (diff)
downloadvyos-1x-bfa969c37711dbda98d407b66600fa789cadc8e1.tar.gz
vyos-1x-bfa969c37711dbda98d407b66600fa789cadc8e1.zip
Merge branch 'T2588' of https://github.com/thomas-mangin/vyos-1x into default-doct
* 'T2588' of https://github.com/thomas-mangin/vyos-1x: xml: T2588: code to extract defaults values from xml
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules4
2 files changed, 5 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 22b4da657..5e14340a8 100644
--- a/debian/control
+++ b/debian/control
@@ -6,6 +6,7 @@ Build-Depends: debhelper (>= 9),
quilt,
python3,
python3-setuptools,
+ python3-xmltodict,
python3-lxml,
python3-nose,
python3-coverage,
diff --git a/debian/rules b/debian/rules
index 3e408b538..c080b8633 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,6 +23,10 @@ override_dh_auto_build:
override_dh_auto_install:
dh_auto_install
+
+ # convert the XML to dictionaries
+ env PYTHONPATH=python python3 python/vyos/xml/generate.py
+
cd python; python3 setup.py install --install-layout=deb --root ../$(DIR); cd ..
# Install scripts