summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2020-12-17 18:30:16 +0100
committerChristian Poessinger <christian@poessinger.com>2020-12-17 17:37:07 +0000
commitbd3ff678b733964c689b52ff1b0d2c838edeb8b8 (patch)
tree901f7a5ecd69cc692d3112d9c53aaa80c239f2c6 /debian
parenta6b35825a78b5fe8c3a91bc4cf6abf0f50a08738 (diff)
downloadvyos-1x-bd3ff678b733964c689b52ff1b0d2c838edeb8b8.tar.gz
vyos-1x-bd3ff678b733964c689b52ff1b0d2c838edeb8b8.zip
xdp: T2666: initial XDP (generic mode) forwarding support
The CLI command 'set interfaces ethernet <interface> offload-options xdp" enables the XDP generic mode on the given interface. vyos@vyos:~$ show interfaces ethernet eth1 eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 xdpgeneric/id:151 qdisc mq state DOWN group default qlen 1000 link/ether 00:50:56:bf:ef:aa brd ff:ff:ff:ff:ff:ff inet6 fe80::250:56ff:febf:efaa/64 scope link tentative valid_lft forever preferred_lft forever Description: fooa XDP code is thankfully copied from [1], thank you for this nice tutorial. NOTE: this is an experimental feature which might break your forwarding/filtering. [1]: https://medium.com/swlh/building-a-xdp-express-data-path-based-peering-router-20db4995da66
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index a0cc7a99b..599572358 100755
--- a/debian/rules
+++ b/debian/rules
@@ -78,6 +78,10 @@ override_dh_auto_install:
mkdir -p $(DIR)/$(VYOS_DATA_DIR)
cp -r data/* $(DIR)/$(VYOS_DATA_DIR)
+ # Install eBPF plugins
+ mkdir -p $(DIR)/$(VYOS_DATA_DIR)/ebpf
+ cp -r src/ebpf/*.o $(DIR)/$(VYOS_DATA_DIR)/ebpf
+
# Install etc configuration files
mkdir -p $(DIR)/etc
cp -r src/etc/* $(DIR)/etc