summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2020-08-27 21:12:55 +0200
committerChristian Poessinger <christian@poessinger.com>2020-08-27 21:12:55 +0200
commit0f8123268da02372cf4e5ee5f552f45fd79fc5e7 (patch)
tree6e9fb3124b3cfb148729dbcf8483a1135110667f /debian
parentefeac80f82810c4d752b9633861d691e36de4385 (diff)
parent756c9153e683be83ab1f2786a72e6ed1e65dd3b5 (diff)
downloadvyos-1x-0f8123268da02372cf4e5ee5f552f45fd79fc5e7.tar.gz
vyos-1x-0f8123268da02372cf4e5ee5f552f45fd79fc5e7.zip
Merge branch 'master' of github.com:vyos/vyos-smoketest into vyos-smoketest-integration (T2832)
* 'master' of github.com:vyos/vyos-smoketest: (153 commits) pppoe-server: test some more values lcd: adjust to cli changes lcd: adapt test to new CLI design pppoe-server: initial smoketest with local and radius auth pppoe: validate dhcpv6 client will be started wireless: validate hostapd/wpa_supplicant is running pppoe: sync to new dhcpv6-pd cli anyconnect: T2812: add basic testing ethernet: check interface disable state router-advert: check 'infinity' option in script logic ssh: config file is now volatile (moved to /run) ipv6: link-local: test address assignment on interfaces router-advert: add initial test mdns-repeater: add basic test pseudo-ethernet: extend smoketests with VIFs l2tpv3: add initial interface test wireless: use library function for loading kernel modules ethernet: test "ip" subtree of interface for e.g. ARP settings pppoe: use assertEqual() service: bcast-relay: add initial tests ...
Diffstat (limited to 'debian')
-rw-r--r--debian/control5
-rwxr-xr-xdebian/rules8
-rw-r--r--debian/vyos-1x-smoketest.install2
-rw-r--r--debian/vyos-1x.install15
4 files changed, 29 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index d6b4420c7..65808de86 100644
--- a/debian/control
+++ b/debian/control
@@ -122,3 +122,8 @@ Depends:
Description: VyOS configuration scripts and data for VMware
Adds configuration files required for VyOS running on VMware hosts.
+Package: vyos-1x-smoketest
+Architecture: all
+Depends:
+ vyos-1x
+Description: VyOS build sanity checking toolkit
diff --git a/debian/rules b/debian/rules
index c080b8633..58bafd333 100755
--- a/debian/rules
+++ b/debian/rules
@@ -91,3 +91,11 @@ override_dh_auto_install:
# Make directory for generated configuration file
mkdir -p $(DIR)/etc/vyos
+
+ # Install smoke test scripts
+ mkdir -p $(DIR)/$(VYOS_LIBEXEC_DIR)/tests/smoke/
+ cp -r smoketest/scripts/* $(DIR)/$(VYOS_LIBEXEC_DIR)/tests/smoke
+
+ # Install system programs
+ mkdir -p $(DIR)/$(VYOS_BIN_DIR)
+ cp -r smoketest/bin/* $(DIR)/$(VYOS_BIN_DIR)
diff --git a/debian/vyos-1x-smoketest.install b/debian/vyos-1x-smoketest.install
new file mode 100644
index 000000000..fdf949557
--- /dev/null
+++ b/debian/vyos-1x-smoketest.install
@@ -0,0 +1,2 @@
+usr/bin/vyos-smoketest
+usr/libexec/vyos/tests/smoke
diff --git a/debian/vyos-1x.install b/debian/vyos-1x.install
index 599f3f3f5..6cd678442 100644
--- a/debian/vyos-1x.install
+++ b/debian/vyos-1x.install
@@ -7,4 +7,17 @@ etc/udev
etc/vyos
lib/
opt/
-usr/
+usr/bin/initial-setup
+usr/bin/vyos-config-file-query
+usr/bin/vyos-config-to-commands
+usr/bin/vyos-config-to-json
+usr/bin/vyos-hostsd-client
+usr/lib
+usr/libexec/vyos/completion
+usr/libexec/vyos/conf_mode
+usr/libexec/vyos/op_mode
+usr/libexec/vyos/services
+usr/libexec/vyos/system
+usr/libexec/vyos/validators
+usr/libexec/vyos/*.py
+usr/share