summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2020-12-26 17:12:29 +0100
committerChristian Poessinger <christian@poessinger.com>2020-12-28 19:42:50 +0100
commit1efd20ab21e75e421487d563fc794a7f97361a3e (patch)
tree189b1860ffe77a2c2349415fc508cc03ab73f1c2 /debian
parentb9a2312f02e40b16d5b85454eadd84dc3cb7bea8 (diff)
downloadvyos-1x-1efd20ab21e75e421487d563fc794a7f97361a3e.tar.gz
vyos-1x-1efd20ab21e75e421487d563fc794a7f97361a3e.zip
webproxy: T563: op-mode: initial command support
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/vyos-1x.install1
3 files changed, 6 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index ccdaa8492..9750f08e2 100644
--- a/debian/control
+++ b/debian/control
@@ -99,6 +99,7 @@ Depends:
python3-pyudev,
python3-six,
python3-tabulate,
+ python3-tqdm,
python3-vici (>= 5.7.2),
python3-voluptuous,
python3-waitress,
diff --git a/debian/rules b/debian/rules
index ab0df7201..5e275b8a3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -51,6 +51,10 @@ override_dh_auto_install:
mkdir -p $(DIR)/$(VYOS_LIBEXEC_DIR)/completion
cp -r src/completion/* $(DIR)/$(VYOS_LIBEXEC_DIR)/completion
+ # Install legacy components
+ mkdir -p $(DIR)/$(VYOS_LIBEXEC_DIR)/legacy
+ cp -r src/legacy/* $(DIR)/$(VYOS_LIBEXEC_DIR)/legacy
+
# Install helper scripts
cp -r src/helpers/* $(DIR)/$(VYOS_LIBEXEC_DIR)/
diff --git a/debian/vyos-1x.install b/debian/vyos-1x.install
index bfc30f7e6..691fa4731 100644
--- a/debian/vyos-1x.install
+++ b/debian/vyos-1x.install
@@ -21,5 +21,6 @@ usr/libexec/vyos/op_mode
usr/libexec/vyos/services
usr/libexec/vyos/system
usr/libexec/vyos/validators
+usr/libexec/vyos/legacy
usr/libexec/vyos/*.py
usr/share