summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDaniil Baturin <daniil@baturin.org>2019-07-02 22:34:59 +0200
committerDaniil Baturin <daniil@baturin.org>2019-07-02 22:34:59 +0200
commit35a429c4ca1923b3e87531f34ca64133d4a82efc (patch)
treed9bfbef82fe30057c01e882b885ad746f263a409 /debian
parent630f398bd23fbfe4e927bf042a7afd3a44f47e08 (diff)
downloadvyos-1x-35a429c4ca1923b3e87531f34ca64133d4a82efc.tar.gz
vyos-1x-35a429c4ca1923b3e87531f34ca64133d4a82efc.zip
Add Debian packaging and LGPL license.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control23
-rw-r--r--debian/copyright35
-rwxr-xr-xdebian/rules28
5 files changed, 92 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 000000000..2b24a8f9e
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+vyos-smoketest (1.0.0) unstable; urgency=medium
+
+ * Initial release
+
+ -- Daniil Baturin <daniil@baturin.org> Tue, 02 Jul 2019 22:29:53 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 000000000..ec635144f
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 000000000..97f8b27ea
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,23 @@
+Source: vyos-smoketest
+Section: contrib/net
+Priority: extra
+Maintainer: VyOS Package Maintainers <maintainers@vyos.net>
+Build-Depends: debhelper (>= 9),
+ quilt,
+ python3,
+ python3-setuptools,
+ quilt,
+ python3-lxml,
+ python3-nose,
+ python3-coverage
+Standards-Version: 3.9.6
+
+Package: vyos-smoketest
+Architecture: all
+Depends: python3,
+ ${python3:Depends},
+ ${shlibs:Depends},
+ ${misc:Depends},
+ vyos-1x
+Description: VyOS build sanity checking toolkit
+ VyOS build sanity checking toolkit
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 000000000..a3260a7a1
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,35 @@
+This package was debianized by Daniil Baturin <daniil@baturin.org> on
+Tue, 02 Jul 2019 22:24:20 +0200
+
+It's original content from the GIT repository <http://github.com/vyos/vyos-smoketest>
+
+Upstream Author:
+
+ <maintainers@vyos.net>
+
+Copyright:
+
+ Copyright (C) 2019 VyOS maintainers and contributors
+ All Rights Reserved.
+
+License:
+
+This program is free software; you can redistribute it and/or modify
+it under the terms of the GNU Lesser General Public License as published by
+the Free Software Foundation; either version 2, or (at your option)
+any later version.
+
+This program is distributed in the hope that it will be useful, but
+WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+General Public License for more details.
+
+A copy of the GNU General Public License is available as
+`/usr/share/common-licenses/GPL' in the Debian GNU/Linux distribution
+or on the World Wide Web at `http://www.gnu.org/copyleft/lgpl.html'.
+You can also obtain it by writing to the Free Software Foundation,
+Free Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
+MA 02110-1301, USA.
+
+The Debian packaging is (C) 2019, Daniil Baturin <daniil@baturin.org> and
+is licensed under the GPL, see above.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 000000000..4ccc23e86
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,28 @@
+#!/usr/bin/make -f
+
+DIR := debian/vyos-smoketest
+VYOS_SBIN_DIR := usr/sbin/
+VYOS_BIN_DIR := usr/bin/
+VYOS_LIBEXEC_DIR := usr/libexec/vyos
+VYOS_DATA_DIR := /usr/share/vyos
+VYOS_CFG_TMPL_DIR := /opt/vyatta/share/vyatta-cfg/templates
+VYOS_OP_TMPL_DIR := /opt/vyatta/share/vyatta-op/templates
+
+MIGRATION_SCRIPTS_DIR := /opt/vyatta/etc/config-migrate/migrate/
+
+SBINDIR := $(DIR)/usr/sbin
+
+%:
+ dh $@ --with python3, --with quilt
+
+override_dh_auto_build:
+ make all
+
+override_dh_auto_install:
+ # Install smoke test scripts
+ mkdir -p $(DIR)/$(VYOS_LIBEXEC_DIR)/tests/smoke/
+ cp -r scripts/* $(DIR)/$(VYOS_LIBEXEC_DIR)/tests/smoke
+
+ # Install system programs
+ mkdir -p $(SBINDIR)
+ cp -r bin/* $(SBINDIR)