summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDaniil Baturin <daniil@baturin.org>2017-09-07 03:27:55 +0200
committerDaniil Baturin <daniil@baturin.org>2017-09-07 03:27:55 +0200
commit41752cbef7b9e647feaa4a889c29fe76ca3a4c9f (patch)
tree7ad4bc50921dff36fa59474e4d07215fc347c13a /debian
parent08ecdea5e7b838e94b6654eb165f0f652ebbb584 (diff)
downloadvyos-1x-41752cbef7b9e647feaa4a889c29fe76ca3a4c9f.tar.gz
vyos-1x-41752cbef7b9e647feaa4a889c29fe76ca3a4c9f.zip
Add interface definition for cron and enable templates building in the makefiles.
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules12
2 files changed, 12 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 71169b1e5..33de6b7ef 100644
--- a/debian/control
+++ b/debian/control
@@ -8,6 +8,6 @@ Standards-Version: 3.9.6
Package: vyos-1x
Architecture: all
-Depends: ${python3:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Depends: python3, ${python3:Depends}, ${shlibs:Depends}, ${misc:Depends}
Description: VyOS configuration scripts and data
VyOS configuration scripts, interface definitions, and everything
diff --git a/debian/rules b/debian/rules
index e76b80267..f070f1f5e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,11 +1,21 @@
#!/usr/bin/make -f
+DIR := debian/vyos-1x
+VYOS_SBIN_DIR := opt/vyatta/sbin/
+VYOS_CFG_TMPL_DIR := /opt/vyatta/share/vyatta-cfg/templates
+
%:
dh $@ --with python3, --with quilt
override_dh_auto_build:
+ make
override_dh_auto_install:
dh_install -pvyos-1x
- cd python; python3 setup.py install --install-layout=deb --root ../debian/vyos-1x; cd ..
+ cd python; python3 setup.py install --install-layout=deb --root $(DIR); cd ..
+
+ mkdir -p $(DIR)/$(VYOS_SBIN_DIR)
+ cp -r src/conf-mode/* $(DIR)/$(VYOS_SBIN_DIR)
+ mkdir -p $(DIR)/$(VYOS_CFG_TMPL_DIR)
+ cp -r templates/* $(DIR)/$(VYOS_CFG_TMPL_DIR)