summaryrefslogtreecommitdiff
path: root/python/setup.py
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2020-06-22 22:08:20 +0200
committerChristian Poessinger <christian@poessinger.com>2020-06-22 22:08:20 +0200
commitbfa969c37711dbda98d407b66600fa789cadc8e1 (patch)
treeac6e510f07add0dd54d48cfcb95328113a74183b /python/setup.py
parente18fe3704a40ef25dfc3e248ae9f83aa053ef174 (diff)
parent88ede50d106c8cea494aacdcd346911b1058ffd1 (diff)
downloadvyos-1x-bfa969c37711dbda98d407b66600fa789cadc8e1.tar.gz
vyos-1x-bfa969c37711dbda98d407b66600fa789cadc8e1.zip
Merge branch 'T2588' of https://github.com/thomas-mangin/vyos-1x into default-doct
* 'T2588' of https://github.com/thomas-mangin/vyos-1x: xml: T2588: code to extract defaults values from xml
Diffstat (limited to 'python/setup.py')
-rw-r--r--python/setup.py10
1 files changed, 8 insertions, 2 deletions
diff --git a/python/setup.py b/python/setup.py
index 9440e7fe7..e2d28bd6b 100644
--- a/python/setup.py
+++ b/python/setup.py
@@ -1,6 +1,13 @@
import os
from setuptools import setup
+def packages(directory):
+ return [
+ _[0].replace('/','.')
+ for _ in os.walk(directory)
+ if os.path.isfile(os.path.join(_[0], '__init__.py'))
+ ]
+
setup(
name = "vyos",
version = "1.3.0",
@@ -10,7 +17,7 @@ setup(
license = "LGPLv2+",
keywords = "vyos",
url = "http://www.vyos.io",
- packages=["vyos","vyos.ifconfig"],
+ packages = packages('vyos'),
long_description="VyOS configuration libraries",
classifiers=[
"Development Status :: 4 - Beta",
@@ -18,4 +25,3 @@ setup(
"License :: OSI Approved :: GNU Lesser General Public License v2 or later (LGPLv2+)",
],
)
-