summaryrefslogtreecommitdiff
path: root/python/setup.py
diff options
context:
space:
mode:
authorThomas Mangin <thomas.mangin@exa.net.uk>2020-06-22 21:04:20 +0100
committerThomas Mangin <thomas.mangin@exa.net.uk>2020-06-22 21:04:20 +0100
commit88ede50d106c8cea494aacdcd346911b1058ffd1 (patch)
treea3fbe5d5010e3d7329e437de0b785d6c136e8c9b /python/setup.py
parent7e258d0f77c005baf27a50160aa8b82b8562975c (diff)
downloadvyos-1x-88ede50d106c8cea494aacdcd346911b1058ffd1.tar.gz
vyos-1x-88ede50d106c8cea494aacdcd346911b1058ffd1.zip
xml: T2588: code to extract defaults values from xml
Diffstat (limited to 'python/setup.py')
-rw-r--r--python/setup.py10
1 files changed, 8 insertions, 2 deletions
diff --git a/python/setup.py b/python/setup.py
index ac7d0b573..61cb8cb4e 100644
--- a/python/setup.py
+++ b/python/setup.py
@@ -1,6 +1,13 @@
import os
from setuptools import setup
+def packages(directory):
+ return [
+ _[0].replace('/','.')
+ for _ in os.walk(directory)
+ if os.path.isfile(os.path.join(_[0], '__init__.py'))
+ ]
+
setup(
name = "vyos",
version = "1.2.0",
@@ -10,7 +17,7 @@ setup(
license = "LGPLv2+",
keywords = "vyos",
url = "http://www.vyos.io",
- packages=["vyos","vyos.ifconfig"],
+ packages = packages('vyos'),
long_description="VyOS configuration libraries",
classifiers=[
"Development Status :: 4 - Beta",
@@ -18,4 +25,3 @@ setup(
"License :: OSI Approved :: GNU Lesser General Public License v2 or later (LGPLv2+)",
],
)
-