summaryrefslogtreecommitdiff
path: root/python/setup.py
diff options
context:
space:
mode:
authorJohn Estabrook <jestabro@vyos.io>2023-01-18 21:32:39 -0600
committerJohn Estabrook <jestabro@vyos.io>2023-01-20 12:01:59 -0600
commit1cfcb3888107249582da60f6e286a5beafbf67f9 (patch)
tree01a701dd72d48f0d3da0e0bef977b48fc8ca994e /python/setup.py
parent1f34027a1cb85c289da0f3b2b74263a80118bee7 (diff)
downloadvyos-1x-1cfcb3888107249582da60f6e286a5beafbf67f9.tar.gz
vyos-1x-1cfcb3888107249582da60f6e286a5beafbf67f9.zip
config-mgmt: T4942: add config_mgmt module and console script
Diffstat (limited to 'python/setup.py')
-rw-r--r--python/setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/python/setup.py b/python/setup.py
index e2d28bd6b..2d614e724 100644
--- a/python/setup.py
+++ b/python/setup.py
@@ -24,4 +24,9 @@ setup(
"Topic :: Utilities",
"License :: OSI Approved :: GNU Lesser General Public License v2 or later (LGPLv2+)",
],
+ entry_points={
+ "console_scripts": [
+ "config-mgmt = vyos.config_mgmt:run",
+ ],
+ },
)