summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules2
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index af42202fc..726a083f2 100644
--- a/debian/control
+++ b/debian/control
@@ -43,7 +43,6 @@ Depends:
## End of Fundamentals
## Python libraries used in multiple modules and scripts
python3,
- python3-certbot-nginx,
python3-cryptography,
python3-hurry.filesize,
python3-inotify,
@@ -146,6 +145,9 @@ Depends:
# For "protocols igmp-proxy"
igmpproxy,
# End "protocols igmp-proxy"
+# For "pki"
+ certbot,
+# End "pki"
# For "service console-server"
conserver-client,
conserver-server,
diff --git a/debian/rules b/debian/rules
index 9a6ab2996..d007089a4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,7 +24,7 @@ DEB_TARGET_ARCH := $(shell dpkg-architecture -qDEB_TARGET_ARCH)
override_dh_strip_nondeterminism:
override_dh_gencontrol:
- dh_gencontrol -- -v$(shell (git describe --tags --long --match 'vyos/*' --dirty 2>/dev/null || echo 0.0-no.git.tag) | sed -E 's%vyos/%%' | sed -E 's%-dirty%+dirty%')
+ dh_gencontrol -- -v$(shell (git describe --tags --long --match 'vyos/*' --match '1.4.*' --dirty 2>/dev/null || echo 0.0-no.git.tag) | sed -E 's%vyos/%%' | sed -E 's%-dirty%+dirty%')
override_dh_auto_build:
make all