summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/compat2
-rw-r--r--debian/control32
-rwxr-xr-xdebian/rules5
-rw-r--r--debian/vyos-1x-vmware.preinst1
-rw-r--r--debian/vyos-1x.install7
-rw-r--r--debian/vyos-1x.postinst33
-rw-r--r--debian/vyos-1x.preinst4
7 files changed, 70 insertions, 14 deletions
diff --git a/debian/compat b/debian/compat
index ec635144f..f599e28b8 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-9
+10
diff --git a/debian/control b/debian/control
index de030310e..c5cbeb7d4 100644
--- a/debian/control
+++ b/debian/control
@@ -4,6 +4,7 @@ Priority: extra
Maintainer: VyOS Package Maintainers <maintainers@vyos.net>
Build-Depends:
debhelper (>= 9),
+ dh-python,
fakeroot,
gcc-multilib [amd64],
clang [amd64],
@@ -30,6 +31,7 @@ Standards-Version: 3.9.6
Package: vyos-1x
Architecture: amd64 arm64
Depends:
+ ${python3:Depends},
accel-ppp,
beep,
bmon,
@@ -41,12 +43,15 @@ Depends:
console-data,
crda,
cron,
+ curl,
dbus,
ddclient (>= 3.9.1),
dropbear,
easy-rsa,
etherwake,
- fastnetmon,
+ ethtool,
+ fdisk,
+ fastnetmon [amd64],
file,
frr (>= 7.5),
frr-pythontools,
@@ -59,6 +64,7 @@ Depends:
ipaddrcheck,
iperf,
iperf3,
+ iproute2,
iputils-arping,
isc-dhcp-client,
isc-dhcp-relay,
@@ -67,23 +73,33 @@ Depends:
keepalived (>=2.0.5),
lcdproc,
libatomic1,
+ libcharon-extra-plugins (>=5.9),
+ libcharon-extauth-plugins (>=5.9),
libndp-tools,
libnetfilter-conntrack3,
libnfnetlink0,
libpam-radius-auth (>= 1.5.0),
+ libqmi-utils,
+ libstrongswan-extra-plugins (>=5.9),
+ libstrongswan-standard-plugins (>=5.9),
libvyosconfig0,
lldpd,
lm-sensors,
lsscsi,
mdns-repeater,
minisign,
+ modemmanager,
mtr-tiny,
+ ndisc6,
+ ndppd,
netplug,
nftables (>= 0.9.3),
nginx-light,
ntp,
ntpdate,
+ nvme-cli,
ocserv,
+ opennhrp,
openssh-server,
openssl,
openvpn,
@@ -97,9 +113,10 @@ Depends:
procps,
python3,
python3-certbot-nginx,
- ${python3:Depends},
+ python3-cryptography,
python3-flask,
python3-hurry.filesize,
+ python3-inotify,
python3-isc-dhcp-leases,
python3-jinja2,
python3-jmespath,
@@ -119,12 +136,18 @@ Depends:
qrencode,
radvd,
salt-minion,
+ sed,
+ smartmontools,
snmp,
snmpd,
+ squashfs-tools,
squid,
squidclient,
squidguard,
ssl-cert,
+ strongswan (>= 5.9),
+ strongswan-swanctl (>= 5.9),
+ sudo,
systemd,
tcpdump,
tcptraceroute,
@@ -135,13 +158,14 @@ Depends:
udp-broadcast-relay,
usb-modeswitch,
usbutils,
+ vyatta-bash,
+ vyatta-cfg,
vyos-http-api-tools,
vyos-utils,
wide-dhcpv6-client,
wireguard-tools,
wireless-regdb,
- wpasupplicant (>= 0.6.7),
- ndppd
+ wpasupplicant (>= 0.6.7)
Description: VyOS configuration scripts and data
VyOS configuration scripts, interface definitions, and everything
diff --git a/debian/rules b/debian/rules
index 8e5aee3e6..70d39c481 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,6 +7,7 @@ VYOS_LIBEXEC_DIR := usr/libexec/vyos
VYOS_DATA_DIR := usr/share/vyos
VYOS_CFG_TMPL_DIR := opt/vyatta/share/vyatta-cfg/templates
VYOS_OP_TMPL_DIR := opt/vyatta/share/vyatta-op/templates
+VYOS_MIBS_DIR := usr/share/snmp/mibs
MIGRATION_SCRIPTS_DIR := opt/vyatta/etc/config-migrate/migrate
SYSTEM_SCRIPTS_DIR := usr/libexec/vyos/system
@@ -84,6 +85,10 @@ override_dh_auto_install:
mkdir -p $(DIR)/$(VYOS_DATA_DIR)
cp -r data/* $(DIR)/$(VYOS_DATA_DIR)
+ # Install SNMP MIBs
+ mkdir -p $(DIR)/$(VYOS_MIBS_DIR)
+ cp -d mibs/* $(DIR)/$(VYOS_MIBS_DIR)
+
# Install etc configuration files
mkdir -p $(DIR)/etc
cp -r src/etc/* $(DIR)/etc
diff --git a/debian/vyos-1x-vmware.preinst b/debian/vyos-1x-vmware.preinst
new file mode 100644
index 000000000..2e612522c
--- /dev/null
+++ b/debian/vyos-1x-vmware.preinst
@@ -0,0 +1 @@
+dpkg-divert --package vyos-1x-vmware --add --rename /etc/vmware-tools/tools.conf
diff --git a/debian/vyos-1x.install b/debian/vyos-1x.install
index 51a1bb38a..2ed25755f 100644
--- a/debian/vyos-1x.install
+++ b/debian/vyos-1x.install
@@ -1,7 +1,12 @@
+etc/cron.hourly
etc/dhcp
+etc/ipsec.d
etc/netplug
-etc/ppp
+etc/opennhrp
etc/rsyslog.d
+etc/securetty
+etc/security
+etc/sudoers.d
etc/systemd
etc/sysctl.d
etc/udev
diff --git a/debian/vyos-1x.postinst b/debian/vyos-1x.postinst
index 8acc87cc8..4b4c4c13e 100644
--- a/debian/vyos-1x.postinst
+++ b/debian/vyos-1x.postinst
@@ -1,13 +1,7 @@
#!/bin/sh -e
-if ! deb-systemd-helper --quiet was-enabled salt-minion.service; then
- # Enables the unit on first installation, creates new
- # symlinks on upgrades if the unit file has changed.
- deb-systemd-helper disable salt-minion.service >/dev/null || true
-fi
-if [ -x "/etc/init.d/salt-minion" ]; then
- update-rc.d -f salt-minion remove >/dev/null
-fi
+# Turn off Debian default for %sudo
+sed -i -e '/^%sudo/d' /etc/sudoers || true
# Add minion user for salt-minion
if ! grep -q '^minion' /etc/passwd; then
@@ -66,3 +60,26 @@ fi
# ensure hte proxy user has a proper shell
chsh -s /bin/sh proxy
+
+# create /opt/vyatta/etc/config/scripts/vyos-postconfig-bootup.script
+POSTCONFIG_SCRIPT=/opt/vyatta/etc/config/scripts/vyos-postconfig-bootup.script
+if [ ! -x $POSTCONFIG_SCRIPT ]; then
+ mkdir -p $(dirname $POSTCONFIG_SCRIPT)
+ touch $POSTCONFIG_SCRIPT
+ chmod 755 $POSTCONFIG_SCRIPT
+ cat <<EOF >>$POSTCONFIG_SCRIPT
+#!/bin/sh
+# This script is executed at boot time after VyOS configuration is fully applied.
+# Any modifications required to work around unfixed bugs
+# or use services not available through the VyOS CLI system can be placed here.
+
+EOF
+fi
+
+# symlink destination is deleted during ISO assembly - this generates some noise
+# when the system boots: systemd-sysv-generator[1881]: stat() failed on
+# /etc/init.d/README, ignoring: No such file or directory. Thus we simply drop
+# the file.
+if [ -L /etc/init.d/README ]; then
+ rm -f /etc/init.d/README
+fi
diff --git a/debian/vyos-1x.preinst b/debian/vyos-1x.preinst
new file mode 100644
index 000000000..45440bf64
--- /dev/null
+++ b/debian/vyos-1x.preinst
@@ -0,0 +1,4 @@
+dpkg-divert --package vyos-1x --add --rename /etc/securetty
+dpkg-divert --package vyos-1x --add --rename /etc/security/capability.conf
+dpkg-divert --package vyos-1x --add --rename /lib/systemd/system/lcdproc.service
+