summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rw-r--r--debian/vyos-1x.postinst11
2 files changed, 12 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index e7aeeda93..5e14340a8 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,6 @@ Build-Depends: debhelper (>= 9),
quilt,
python3,
python3-setuptools,
- quilt,
python3-xmltodict,
python3-lxml,
python3-nose,
@@ -36,6 +35,7 @@ Depends: python3,
python3-jmespath,
python3-xmltodict,
python3-pyudev,
+ python3-voluptuous,
bsdmainutils,
cron,
etherwake,
diff --git a/debian/vyos-1x.postinst b/debian/vyos-1x.postinst
index a308401ee..dc129cb54 100644
--- a/debian/vyos-1x.postinst
+++ b/debian/vyos-1x.postinst
@@ -19,3 +19,14 @@ if ! grep -q '^minion' /etc/passwd; then
adduser --quiet minion disk
adduser --quiet minion users
fi
+
+# add hostsd group for vyos-hostsd
+if ! grep -q '^hostsd' /etc/group; then
+ addgroup --quiet --system hostsd
+fi
+
+# add dhcpd user for dhcp-server
+if ! grep -q '^dhcpd' /etc/passwd; then
+ adduser --quiet --system --disabled-login --no-create-home --home /run/dhcp-server dhcpd
+ adduser --quiet dhcpd hostsd
+fi