summaryrefslogtreecommitdiff
path: root/python/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'python/setup.py')
-rw-r--r--python/setup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/python/setup.py b/python/setup.py
new file mode 100644
index 000000000..e2d28bd6b
--- /dev/null
+++ b/python/setup.py
@@ -0,0 +1,27 @@
+import os
+from setuptools import setup
+
+def packages(directory):
+ return [
+ _[0].replace('/','.')
+ for _ in os.walk(directory)
+ if os.path.isfile(os.path.join(_[0], '__init__.py'))
+ ]
+
+setup(
+ name = "vyos",
+ version = "1.3.0",
+ author = "VyOS maintainers and contributors",
+ author_email = "maintainers@vyos.net",
+ description = ("VyOS configuration libraries."),
+ license = "LGPLv2+",
+ keywords = "vyos",
+ url = "http://www.vyos.io",
+ packages = packages('vyos'),
+ long_description="VyOS configuration libraries",
+ classifiers=[
+ "Development Status :: 4 - Beta",
+ "Topic :: Utilities",
+ "License :: OSI Approved :: GNU Lesser General Public License v2 or later (LGPLv2+)",
+ ],
+)