From 35a429c4ca1923b3e87531f34ca64133d4a82efc Mon Sep 17 00:00:00 2001
From: Daniil Baturin <daniil@baturin.org>
Date: Tue, 2 Jul 2019 22:34:59 +0200
Subject: Add Debian packaging and LGPL license.

---
 debian/rules | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
 create mode 100755 debian/rules

(limited to 'debian/rules')

diff --git a/debian/rules b/debian/rules
new file mode 100755
index 000000000..4ccc23e86
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,28 @@
+#!/usr/bin/make -f
+
+DIR := debian/vyos-smoketest
+VYOS_SBIN_DIR := usr/sbin/
+VYOS_BIN_DIR := usr/bin/
+VYOS_LIBEXEC_DIR := usr/libexec/vyos
+VYOS_DATA_DIR := /usr/share/vyos
+VYOS_CFG_TMPL_DIR := /opt/vyatta/share/vyatta-cfg/templates
+VYOS_OP_TMPL_DIR := /opt/vyatta/share/vyatta-op/templates
+
+MIGRATION_SCRIPTS_DIR := /opt/vyatta/etc/config-migrate/migrate/
+
+SBINDIR := $(DIR)/usr/sbin
+
+%:
+	dh $@ --with python3, --with quilt
+
+override_dh_auto_build:
+	make all
+
+override_dh_auto_install:
+	# Install smoke test scripts
+	mkdir -p $(DIR)/$(VYOS_LIBEXEC_DIR)/tests/smoke/
+	cp -r scripts/* $(DIR)/$(VYOS_LIBEXEC_DIR)/tests/smoke
+
+	# Install system programs
+	mkdir -p $(SBINDIR)
+	cp -r bin/* $(SBINDIR)
-- 
cgit v1.2.3


From ae2c359c2938466001359823d4b2a97bd360a889 Mon Sep 17 00:00:00 2001
From: Christian Poessinger <christian@poessinger.com>
Date: Sat, 28 Dec 2019 09:43:50 +0100
Subject: Debian: install binary to /usr/bin

---
 debian/rules | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

(limited to 'debian/rules')

diff --git a/debian/rules b/debian/rules
index 4ccc23e86..526fb8537 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,6 @@
 #!/usr/bin/make -f
 
 DIR := debian/vyos-smoketest
-VYOS_SBIN_DIR := usr/sbin/
 VYOS_BIN_DIR := usr/bin/
 VYOS_LIBEXEC_DIR := usr/libexec/vyos
 VYOS_DATA_DIR := /usr/share/vyos
@@ -10,8 +9,6 @@ VYOS_OP_TMPL_DIR := /opt/vyatta/share/vyatta-op/templates
 
 MIGRATION_SCRIPTS_DIR := /opt/vyatta/etc/config-migrate/migrate/
 
-SBINDIR := $(DIR)/usr/sbin
-
 %:
 	dh $@ --with python3, --with quilt
 
@@ -24,5 +21,5 @@ override_dh_auto_install:
 	cp -r scripts/* $(DIR)/$(VYOS_LIBEXEC_DIR)/tests/smoke
 
 	# Install system programs
-	mkdir -p $(SBINDIR)
-	cp -r bin/* $(SBINDIR)
+	mkdir -p $(DIR)/$(VYOS_BIN_DIR)
+	cp -r bin/* $(DIR)/$(VYOS_BIN_DIR)
-- 
cgit v1.2.3