From 698c5a40b2ece2f3eb41ad932660f7ceb1f80092 Mon Sep 17 00:00:00 2001
From: Christian Poessinger <christian@poessinger.com>
Date: Sun, 4 Nov 2018 11:47:51 +0100
Subject: T959: XML/Python rewrite of "protocol igmp-proxy" and op-mode
 commands

Examples:
=========

CFG commands:

  vyos@vyos# set protocols igmp-proxy disable-quickleave
  vyos@vyos# set protocols igmp-proxy interface eth0 alt-subnet '172.16.35.0/24'
  vyos@vyos# set protocols igmp-proxy interface eth0 alt-subnet '172.31.0.0/24'
  vyos@vyos# set protocols igmp-proxy interface eth0 role 'upstream'
  vyos@vyos# set protocols igmp-proxy interface eth1 role 'downstream'

  vyos@vyos# show protocols
   igmp-proxy {
       disable-quickleave
       interface eth0 {
           alt-subnet 172.16.35.0/24
           alt-subnet 172.31.0.0/24
           role upstream
       }
       interface eth1 {
           role downstream
       }
   }

OP mode commands:
-----------------

  vyos@vyos:~$ show ip multicast interface
   Interface  BytesIn      PktsIn       BytesOut     PktsOut      Local
   eth0       0.0b         0            0.0b         0            xxx.xxx.xxx.65
   eth1       0.0b         0            0.0b         0            xxx.xxx.xx.201

  vyos@vyos:~$ show ip multicast mfc
  Group           Origin          Pkts         Bytes        Wrong   In      Out
  xxx.x.xx.1      xxx.xx.0.1      10           9.81KB       0       eth0    eth1
  xxx.x.xx.2      xxx.xx.0.1                                        --
---
 debian/control | 1 +
 debian/rules   | 4 ++++
 2 files changed, 5 insertions(+)

(limited to 'debian')

diff --git a/debian/control b/debian/control
index 05b4f5320..a68598fd5 100644
--- a/debian/control
+++ b/debian/control
@@ -46,6 +46,7 @@ Depends: python3,
   keepalived (>=2.0.5),
   wireguard,
   tftpd-hpa,
+  igmpproxy,
   ${shlibs:Depends},
   ${misc:Depends}
 Description: VyOS configuration scripts and data
diff --git a/debian/rules b/debian/rules
index 15dfec551..663aff4d9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -64,3 +64,7 @@ override_dh_auto_install:
 	# Install data files
 	mkdir -p $(DIR)/$(VYOS_DATA_DIR)
 	cp -r data/* $(DIR)/$(VYOS_DATA_DIR)
+
+	# Install etc configuration files
+	mkdir -p $(DIR)/etc
+	cp -r src/etc/* $(DIR)/etc
-- 
cgit v1.2.3