summaryrefslogtreecommitdiff
path: root/packages/dropbear/patches/0001-Enable-PAM-support.patch
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2022-01-16 21:07:07 +0100
committerChristian Poessinger <christian@poessinger.com>2022-01-16 21:10:43 +0100
commit52f75193f3afe799017e17504d5785aa7817d455 (patch)
tree44884053dfa2ad109303152469e79b0bca42e71d /packages/dropbear/patches/0001-Enable-PAM-support.patch
parent4ce1c21078a0f6890c0a7004285d8f393a4156b3 (diff)
downloadvyos-build-52f75193f3afe799017e17504d5785aa7817d455.tar.gz
vyos-build-52f75193f3afe799017e17504d5785aa7817d455.zip
packages: T3164: build Dropbear from source with PAM support
Dropbear version shipped in Debian does not have PAM support enabled. For the VyOS console server it would be nice to have the possibility to use RADIUS authentication.
Diffstat (limited to 'packages/dropbear/patches/0001-Enable-PAM-support.patch')
-rw-r--r--packages/dropbear/patches/0001-Enable-PAM-support.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/packages/dropbear/patches/0001-Enable-PAM-support.patch b/packages/dropbear/patches/0001-Enable-PAM-support.patch
new file mode 100644
index 00000000..a9713225
--- /dev/null
+++ b/packages/dropbear/patches/0001-Enable-PAM-support.patch
@@ -0,0 +1,46 @@
+From 3ac8b338e248801eca917e6091ff6b601e55a1fc Mon Sep 17 00:00:00 2001
+From: Christian Poessinger <christian@poessinger.com>
+Date: Sun, 16 Jan 2022 21:04:35 +0100
+Subject: [PATCH] Enable PAM support
+
+---
+ debian/rules | 2 +-
+ default_options.h | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/debian/rules b/debian/rules
+index 673a5a3..4092be7 100755
+--- a/debian/rules
++++ b/debian/rules
+@@ -27,5 +27,5 @@ override_dh_installinit:
+ dh_installinit -R --name dropbear
+
+ override_dh_auto_configure:
+- dh_auto_configure -- --disable-bundled-libtom \
++ dh_auto_configure -- --disable-bundled-libtom --enable-pam \
+ CC='$(CC)' CFLAGS='$(CFLAGS)' $(CONFFLAGS)
+diff --git a/default_options.h b/default_options.h
+index 375506d..e4fc5bf 100644
+--- a/default_options.h
++++ b/default_options.h
+@@ -193,7 +193,7 @@ group1 in Dropbear server too */
+
+ /* Authentication Types - at least one required.
+ RFC Draft requires pubkey auth, and recommends password */
+-#define DROPBEAR_SVR_PASSWORD_AUTH 1
++#define DROPBEAR_SVR_PASSWORD_AUTH 0
+
+ /* Note: PAM auth is quite simple and only works for PAM modules which just do
+ * a simple "Login: " "Password: " (you can edit the strings in svr-authpam.c).
+@@ -201,7 +201,7 @@ group1 in Dropbear server too */
+ * but there's an interface via a PAM module. It won't work for more complex
+ * PAM challenge/response.
+ * You can't enable both PASSWORD and PAM. */
+-#define DROPBEAR_SVR_PAM_AUTH 0
++#define DROPBEAR_SVR_PAM_AUTH 1
+
+ /* ~/.ssh/authorized_keys authentication */
+ #define DROPBEAR_SVR_PUBKEY_AUTH 1
+--
+2.20.1
+