summaryrefslogtreecommitdiff
path: root/packages/dropbear
diff options
context:
space:
mode:
authorViacheslav Hletenko <v.gletenko@vyos.io>2024-10-02 08:02:51 +0000
committerViacheslav Hletenko <v.gletenko@vyos.io>2024-10-02 08:02:51 +0000
commit2fed892f2746561207aa21a2660f4d8f3f79d24e (patch)
tree334ab850ec3035058d9ef26696b608eb96dfc359 /packages/dropbear
parentc89609e997f5a9110bd148128df870e6c683c5f7 (diff)
downloadvyos-build-2fed892f2746561207aa21a2660f4d8f3f79d24e.tar.gz
vyos-build-2fed892f2746561207aa21a2660f4d8f3f79d24e.zip
T6754: Delete Jenkins build packages
Diffstat (limited to 'packages/dropbear')
-rw-r--r--packages/dropbear/.gitignore1
-rw-r--r--packages/dropbear/Jenkinsfile30
-rwxr-xr-xpackages/dropbear/build.sh27
-rw-r--r--packages/dropbear/patches/0001-Enable-PAM-support.patch61
4 files changed, 0 insertions, 119 deletions
diff --git a/packages/dropbear/.gitignore b/packages/dropbear/.gitignore
deleted file mode 100644
index 3f3a2a1c..00000000
--- a/packages/dropbear/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-dropbear/
diff --git a/packages/dropbear/Jenkinsfile b/packages/dropbear/Jenkinsfile
deleted file mode 100644
index 539d7578..00000000
--- a/packages/dropbear/Jenkinsfile
+++ /dev/null
@@ -1,30 +0,0 @@
-// Copyright (C) 2022-2024 VyOS maintainers and contributors
-//
-// This program is free software; you can redistribute it and/or modify
-// in order to easy exprort images built to "external" world
-// it under the terms of the GNU General Public License version 2 or later as
-// published by the Free Software Foundation.
-//
-// This program is distributed in the hope that it will be useful,
-// but WITHOUT ANY WARRANTY; without even the implied warranty of
-// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-// GNU General Public License for more details.
-//
-// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
-@NonCPS
-
-// Using a version specifier library, use 'current' branch. The underscore (_)
-// is not a typo! You need this underscore if the line immediately after the
-// @Library annotation is not an import statement!
-@Library('vyos-build@current')_
-
-def pkgList = [
- ['name': 'dropbear',
- 'scmCommit': 'debian/2022.83-1+deb12u1',
- 'scmUrl': 'https://salsa.debian.org/debian/dropbear.git',
- 'buildCmd': 'sudo mk-build-deps --install --tool "apt-get --yes --no-install-recommends"; cd ..; ./build.sh'],
-]
-
-// Start package build using library function from https://github.com/vyos/vyos-build
-buildPackage('dropbear', pkgList, null, true, "**/packages/dropbear/**")
diff --git a/packages/dropbear/build.sh b/packages/dropbear/build.sh
deleted file mode 100755
index 9376fa7a..00000000
--- a/packages/dropbear/build.sh
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/sh
-CWD=$(pwd)
-set -e
-
-SRC=dropbear
-if [ ! -d ${SRC} ]; then
- echo "Source directory does not exists, please 'git clone'"
- exit 1
-fi
-
-PATCH_DIR=${CWD}/patches
-if [ -d $PATCH_DIR ]; then
- for patch in $(ls ${PATCH_DIR})
- do
- echo "I: Apply patch: ${patch} to main repository"
- cp ${PATCH_DIR}/${patch} ${SRC}/debian/patches/
- echo ${patch} >> ${SRC}/debian/patches/series
- done
-fi
-
-cd ${SRC}
-
-echo "I: Installing build dependencies"
-sudo apt-get install -y libpam0g-dev
-
-echo "I: Build Debian Package"
-dpkg-buildpackage -uc -us -tc -b
diff --git a/packages/dropbear/patches/0001-Enable-PAM-support.patch b/packages/dropbear/patches/0001-Enable-PAM-support.patch
deleted file mode 100644
index fa6cf620..00000000
--- a/packages/dropbear/patches/0001-Enable-PAM-support.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 861bfb53de5909e25a952a83654c63de61af02b5 Mon Sep 17 00:00:00 2001
-From: Christian Breunig <christian@breunig.cc>
-Date: Sun, 28 May 2023 15:45:32 +0200
-Subject: [PATCH] Enable PAM support
-
----
- debian/control | 1 +
- debian/rules | 2 +-
- default_options.h | 4 ++--
- 3 files changed, 4 insertions(+), 3 deletions(-)
-
-diff --git a/debian/control b/debian/control
-index 77ea036..b252b97 100644
---- a/debian/control
-+++ b/debian/control
-@@ -6,6 +6,7 @@ Build-Depends: debhelper,
- debhelper-compat (= 13),
- libtomcrypt-dev (>= 1.18.2~),
- libtommath-dev (>= 1.2.0~),
-+ libpam0g-dev,
- libz-dev
- Rules-Requires-Root: no
- Standards-Version: 4.6.1
-diff --git a/debian/rules b/debian/rules
-index 7dab64c..ce11aa4 100755
---- a/debian/rules
-+++ b/debian/rules
-@@ -24,7 +24,7 @@ endif
- dh $@
-
- override_dh_auto_configure:
-- dh_auto_configure -- --disable-bundled-libtom \
-+ dh_auto_configure -- --disable-bundled-libtom --enable-pam \
- CC='$(CC)' CFLAGS='$(CFLAGS)' $(CONFFLAGS)
-
- execute_before_dh_auto_build:
-diff --git a/default_options.h b/default_options.h
-index 5132775..e7d274c 100644
---- a/default_options.h
-+++ b/default_options.h
-@@ -223,7 +223,7 @@ group1 in Dropbear server too */
-
- /* Authentication Types - at least one required.
- RFC Draft requires pubkey auth, and recommends password */
--#define DROPBEAR_SVR_PASSWORD_AUTH 1
-+#define DROPBEAR_SVR_PASSWORD_AUTH 0
-
- /* Note: PAM auth is quite simple and only works for PAM modules which just do
- * a simple "Login: " "Password: " (you can edit the strings in svr-authpam.c).
-@@ -231,7 +231,7 @@ group1 in Dropbear server too */
- * but there's an interface via a PAM module. It won't work for more complex
- * PAM challenge/response.
- * You can't enable both PASSWORD and PAM. */
--#define DROPBEAR_SVR_PAM_AUTH 0
-+#define DROPBEAR_SVR_PAM_AUTH 1
-
- /* ~/.ssh/authorized_keys authentication.
- * You must define DROPBEAR_SVR_PUBKEY_AUTH in order to use plugins. */
---
-2.30.2
-