summaryrefslogtreecommitdiff
path: root/packages/linux-kernel/patches/kernel/0004-perf-fix-compilation-error-due-to-discarded-const-qu.patch
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2020-10-17 22:37:28 +0200
committerChristian Poessinger <christian@poessinger.com>2020-10-17 22:37:28 +0200
commit4e89180cd6d417e8ccfadcc0d62a0a1e1567d384 (patch)
tree48358e78e9d947e7bb22ce659c0b4c00c46683ac /packages/linux-kernel/patches/kernel/0004-perf-fix-compilation-error-due-to-discarded-const-qu.patch
parent62c4d3d511442d4d6321b2ee1c811ade2a274c96 (diff)
downloadvyos-build-4e89180cd6d417e8ccfadcc0d62a0a1e1567d384.tar.gz
vyos-build-4e89180cd6d417e8ccfadcc0d62a0a1e1567d384.zip
Kernel: T2990: Update Linux Kernel to v4.19.152
Diffstat (limited to 'packages/linux-kernel/patches/kernel/0004-perf-fix-compilation-error-due-to-discarded-const-qu.patch')
-rw-r--r--packages/linux-kernel/patches/kernel/0004-perf-fix-compilation-error-due-to-discarded-const-qu.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/linux-kernel/patches/kernel/0004-perf-fix-compilation-error-due-to-discarded-const-qu.patch b/packages/linux-kernel/patches/kernel/0004-perf-fix-compilation-error-due-to-discarded-const-qu.patch
new file mode 100644
index 00000000..35c392f7
--- /dev/null
+++ b/packages/linux-kernel/patches/kernel/0004-perf-fix-compilation-error-due-to-discarded-const-qu.patch
@@ -0,0 +1,31 @@
+From b61355d12854a6a400e4ddfc79f2f849ac9656dc Mon Sep 17 00:00:00 2001
+From: Christian Poessinger <christian@poessinger.com>
+Date: Sat, 17 Oct 2020 17:09:26 +0000
+Subject: [PATCH] perf: fix compilation error due to discarded const qualifier
+
+---
+ tools/perf/Makefile.config | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tools/perf/Makefile.config b/tools/perf/Makefile.config
+index ae0c5bee8014..51a48ea869dd 100644
+--- a/tools/perf/Makefile.config
++++ b/tools/perf/Makefile.config
+@@ -230,12 +230,12 @@ FEATURE_CHECK_LDFLAGS-libpython-version := $(PYTHON_EMBED_LDOPTS)
+ CFLAGS += -fno-omit-frame-pointer
+ CFLAGS += -ggdb3
+ CFLAGS += -funwind-tables
+-CFLAGS += -Wall
++CFLAGS += -Wno-discarded-qualifiers
+ CFLAGS += -Wextra
+ CFLAGS += -std=gnu99
+
+ CXXFLAGS += -std=gnu++11 -fno-exceptions -fno-rtti
+-CXXFLAGS += -Wall
++CXXFLAGS += -Wno-discarded-qualifiers
+ CXXFLAGS += -fno-omit-frame-pointer
+ CXXFLAGS += -ggdb3
+ CXXFLAGS += -funwind-tables
+--
+2.20.1
+