summaryrefslogtreecommitdiff
path: root/packages/linux-kernel/patches/wireguard-linux-compat/0001-Debian-build-wireguard-modules-package.patch
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2020-09-12 23:09:09 +0200
committerChristian Poessinger <christian@poessinger.com>2020-09-12 23:09:09 +0200
commitc9eaf71fe0e4da8ffa9487832d60743a43586b56 (patch)
treea1734afd1ce53ad9e69eb1a2d344df2210daf65b /packages/linux-kernel/patches/wireguard-linux-compat/0001-Debian-build-wireguard-modules-package.patch
parent0b69d007405cacb680fc8a6130f2e4f9765ca977 (diff)
downloadvyos-build-c9eaf71fe0e4da8ffa9487832d60743a43586b56.tar.gz
vyos-build-c9eaf71fe0e4da8ffa9487832d60743a43586b56.zip
Revert "Kernel: T2843: upgrade Kernel to v5.8.5"
This reverts commit 78c43c2078e292ac9b53d2d6a41a47466d283914. Unfortunately we must revert the Kernel upgrade as there are two problematic issues. One which is the break of ABI functionality with parted [1] and second the internal cryptop API [2] which removed required literals for the build of Intel QAT acceleration. In the two weeks running 5.8 we still learned a lot - we experienced a performance improvement of ~30% when doing NAT @ > 10GBit/s and also utilizing the build in updated drivers for Intel NICs and WireGuard. We are looking forward to the release of this years LTS kernel and we hope to ship this in the final 1.3 release. 1: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-5.8.y&id=692d062655 2: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-5.5.y&id=d63007eb95
Diffstat (limited to 'packages/linux-kernel/patches/wireguard-linux-compat/0001-Debian-build-wireguard-modules-package.patch')
-rw-r--r--packages/linux-kernel/patches/wireguard-linux-compat/0001-Debian-build-wireguard-modules-package.patch74
1 files changed, 74 insertions, 0 deletions
diff --git a/packages/linux-kernel/patches/wireguard-linux-compat/0001-Debian-build-wireguard-modules-package.patch b/packages/linux-kernel/patches/wireguard-linux-compat/0001-Debian-build-wireguard-modules-package.patch
new file mode 100644
index 00000000..4b5e3b03
--- /dev/null
+++ b/packages/linux-kernel/patches/wireguard-linux-compat/0001-Debian-build-wireguard-modules-package.patch
@@ -0,0 +1,74 @@
+From e5fa65c772eac4f577642038031da360f11e925c Mon Sep 17 00:00:00 2001
+From: Christian Poessinger <christian@poessinger.com>
+Date: Sun, 30 Aug 2020 09:26:59 +0200
+Subject: [PATCH] Debian: build wireguard-modules package
+
+VyOS requires a pre build binary of the WireGuard package over a DKMS build.
+Change the build rules to produce the binary over the source package for DKMS.
+---
+ debian/control | 10 +++-------
+ debian/rules | 9 ++++-----
+ 2 files changed, 7 insertions(+), 12 deletions(-)
+
+diff --git a/debian/control b/debian/control
+index d65b8b5..e7be383 100644
+--- a/debian/control
++++ b/debian/control
+@@ -5,15 +5,14 @@ Maintainer: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
+ Uploaders:
+ Unit 193 <unit193@debian.org>,
+ Build-Depends:
+- debhelper-compat (= 13),
+- dkms,
++ debhelper-compat (= 12)
+ Standards-Version: 4.5.0
+ Homepage: https://www.wireguard.com
+ Vcs-Git: https://salsa.debian.org/debian/wireguard-linux-compat.git -b debian/buster-backports
+ Vcs-Browser: https://salsa.debian.org/debian/wireguard-linux-compat
+ Rules-Requires-Root: no
+
+-Package: wireguard-dkms
++Package: wireguard-modules
+ Architecture: all
+ Section: kernel
+ Depends:
+@@ -22,7 +21,7 @@ Depends:
+ Recommends:
+ wireguard (>= 0.0.20191219),
+ wireguard-tools (>= 0.0.20191219),
+-Description: fast, modern, secure kernel VPN tunnel (DKMS version)
++Description: fast, modern, secure kernel VPN tunnel (Kernel module)
+ WireGuard is a novel VPN that runs inside the Linux Kernel and uses
+ state-of-the-art cryptography (the "Noise" protocol). It aims to be
+ faster, simpler, leaner, and more useful than IPSec, while avoiding
+@@ -30,6 +29,3 @@ Description: fast, modern, secure kernel VPN tunnel (DKMS version)
+ than OpenVPN. WireGuard is designed as a general purpose VPN for
+ running on embedded interfaces and super computers alike, fit for
+ many different circumstances. It runs over UDP.
+- .
+- This package uses DKMS to automatically build the wireguard kernel
+- module.
+diff --git a/debian/rules b/debian/rules
+index 4fbedc6..4d93243 100755
+--- a/debian/rules
++++ b/debian/rules
+@@ -6,12 +6,11 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+ export DEB_VERSION_UPSTREAM
+
+ WIREGUARD_ARGS = V=1
++KERNEL_VERSION := $(shell cat "${KERNELDIR}"/include/config/kernel.release)
+
+ %:
+- dh $@ --with dkms
++ dh $@
+
+ override_dh_auto_install-indep:
+- $(MAKE) -C src DESTDIR=../debian/wireguard-dkms DKMSDIR=/usr/src/wireguard-$(DEB_VERSION_UPSTREAM) dkms-install
+-
+-override_dh_dkms:
+- dh_dkms -p wireguard-dkms -- src/dkms.conf
++ $(MAKE) -C src module
++ echo "src/wireguard.ko /lib/modules/$(KERNEL_VERSION)/extra" > debian/wireguard-modules.install
+--
+2.20.1
+