summaryrefslogtreecommitdiff
path: root/packages/pyhumps
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2022-10-29 19:29:47 +0200
committerChristian Poessinger <christian@poessinger.com>2022-10-29 19:29:47 +0200
commit75784affbe1d15f8b57b387c8f7df5863f3c17e0 (patch)
tree8520c5ee7d7db4f519bbd4067f1e332871c36ee8 /packages/pyhumps
parent21118557c0d4080cff99c09c53df815b0dd64ea7 (diff)
downloadvyos-build-75784affbe1d15f8b57b387c8f7df5863f3c17e0.tar.gz
vyos-build-75784affbe1d15f8b57b387c8f7df5863f3c17e0.zip
pyhumps: add initial package build
Diffstat (limited to 'packages/pyhumps')
-rw-r--r--packages/pyhumps/.gitignore6
-rw-r--r--packages/pyhumps/Jenkinsfile30
2 files changed, 36 insertions, 0 deletions
diff --git a/packages/pyhumps/.gitignore b/packages/pyhumps/.gitignore
new file mode 100644
index 00000000..d06c60e5
--- /dev/null
+++ b/packages/pyhumps/.gitignore
@@ -0,0 +1,6 @@
+humps/
+*.deb
+*.dsc
+*.buildinfo
+*.changes
+*.git
diff --git a/packages/pyhumps/Jenkinsfile b/packages/pyhumps/Jenkinsfile
new file mode 100644
index 00000000..94cd4598
--- /dev/null
+++ b/packages/pyhumps/Jenkinsfile
@@ -0,0 +1,30 @@
+// Copyright (C) 2022 VyOS maintainers and contributors
+//
+// This program is free software; you can redistribute it and/or modify
+// in order to easy exprort images built to "external" world
+// it under the terms of the GNU General Public License version 2 or later as
+// published by the Free Software Foundation.
+//
+// This program is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with this program. If not, see <http://www.gnu.org/licenses/>.
+@NonCPS
+
+// Using a version specifier library, use 'current' branch. The underscore (_)
+// is not a typo! You need this underscore if the line immediately after the
+// @Library annotation is not an import statement!
+@Library('vyos-build@current')_
+
+def pkgList = [
+ ['name': 'humps',
+ 'scmCommit': 'v3.8.0',
+ 'scmUrl': 'https://github.com/nficano/humps.git',
+ 'buildCmd': 'python setup.py --command-packages=stdeb.command bdist_deb; cp deb_dist/*.deb ..'],
+]
+
+// Start package build using library function from https://github.com/vyos/vyos-build
+buildPackage('owamp', pkgList, null, true, "**/packages/pyhumps/*")