summaryrefslogtreecommitdiff
path: root/packages/vpp/patches
diff options
context:
space:
mode:
authorzsdc <taras@vyos.io>2023-06-20 15:58:56 +0300
committerzsdc <taras@vyos.io>2023-06-20 18:04:07 +0300
commitfee69c5c7cafb2959b8b46b22c105b9c1eb82176 (patch)
tree27d09e1bd37b8e32ae3524003d4dc6211e3956ef /packages/vpp/patches
parentdeb4cb7f4d4b3f5a9b132b7c4528d4b94329a89f (diff)
downloadvyos-build-fee69c5c7cafb2959b8b46b22c105b9c1eb82176.tar.gz
vyos-build-fee69c5c7cafb2959b8b46b22c105b9c1eb82176.zip
VPP: T1797: Added build scripts for VPP
Diffstat (limited to 'packages/vpp/patches')
-rw-r--r--packages/vpp/patches/vpp/0001-Debian-12-compatible-build.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/packages/vpp/patches/vpp/0001-Debian-12-compatible-build.patch b/packages/vpp/patches/vpp/0001-Debian-12-compatible-build.patch
new file mode 100644
index 00000000..786e4556
--- /dev/null
+++ b/packages/vpp/patches/vpp/0001-Debian-12-compatible-build.patch
@@ -0,0 +1,54 @@
+From 3a4e62ad4844e84e93367a19cf1fae0191e677c6 Mon Sep 17 00:00:00 2001
+From: zsdc <taras@vyos.io>
+Date: Mon, 19 Jun 2023 16:39:04 +0300
+Subject: [PATCH] Debian 12 compatible build
+
+---
+ Makefile | 4 ++++
+ build/external/Makefile | 3 +--
+ src/plugins/af_xdp/{CMakeLists.txt => CMakeLists.txt.disable} | 0
+ 3 files changed, 5 insertions(+), 2 deletions(-)
+ rename src/plugins/af_xdp/{CMakeLists.txt => CMakeLists.txt.disable} (100%)
+
+diff --git a/Makefile b/Makefile
+index 88d42dfe4..9c10b62c6 100644
+--- a/Makefile
++++ b/Makefile
+@@ -103,6 +103,10 @@ else ifeq ($(OS_ID)-$(OS_VERSION_ID),debian-11)
+ DEB_DEPENDS += virtualenv
+ DEB_DEPENDS += clang clang-format-11
+ LIBFFI=libffi7
++else ifeq ($(OS_ID)-$(OS_VERSION_ID),debian-12)
++ DEB_DEPENDS += virtualenv
++ DEB_DEPENDS += clang clang-format
++ LIBFFI=libffi8
+ else
+ DEB_DEPENDS += clang-11 clang-format-11
+ LIBFFI=libffi7
+diff --git a/build/external/Makefile b/build/external/Makefile
+index d648f4fa1..8a4d8e115 100644
+--- a/build/external/Makefile
++++ b/build/external/Makefile
+@@ -40,14 +40,13 @@ include packages/ipsec-mb.mk
+ include packages/quicly.mk
+ include packages/rdma-core.mk
+ include packages/dpdk.mk
+-include packages/xdp-tools.mk
+
+ .PHONY: clean
+ clean:
+ @rm -rf $(B) $(I)
+
+ .PHONY: install
+-install: $(if $(ARCH_X86_64), ipsec-mb-install) dpdk-install rdma-core-install quicly-install xdp-tools-install
++install: $(if $(ARCH_X86_64), ipsec-mb-install) dpdk-install rdma-core-install quicly-install
+
+ .PHONY: config
+ config: $(if $(ARCH_X86_64), ipsec-mb-config) dpdk-config rdma-core-config quicly-build
+diff --git a/src/plugins/af_xdp/CMakeLists.txt b/src/plugins/af_xdp/CMakeLists.txt.disable
+similarity index 100%
+rename from src/plugins/af_xdp/CMakeLists.txt
+rename to src/plugins/af_xdp/CMakeLists.txt.disable
+--
+2.34.1
+