summaryrefslogtreecommitdiff
path: root/packages/fastnetmon
diff options
context:
space:
mode:
Diffstat (limited to 'packages/fastnetmon')
-rw-r--r--packages/fastnetmon/.gitignore2
-rw-r--r--packages/fastnetmon/Jenkinsfile34
-rwxr-xr-xpackages/fastnetmon/build.sh16
3 files changed, 0 insertions, 52 deletions
diff --git a/packages/fastnetmon/.gitignore b/packages/fastnetmon/.gitignore
deleted file mode 100644
index 6831db67..00000000
--- a/packages/fastnetmon/.gitignore
+++ /dev/null
@@ -1,2 +0,0 @@
-fastnetmon/
-fastnetmon-debian-salsa/
diff --git a/packages/fastnetmon/Jenkinsfile b/packages/fastnetmon/Jenkinsfile
deleted file mode 100644
index 710b58ff..00000000
--- a/packages/fastnetmon/Jenkinsfile
+++ /dev/null
@@ -1,34 +0,0 @@
-// Copyright (C) 2022 VyOS maintainers and contributors
-//
-// This program is free software; you can redistribute it and/or modify
-// in order to easy exprort images built to "external" world
-// it under the terms of the GNU General Public License version 2 or later as
-// published by the Free Software Foundation.
-//
-// This program is distributed in the hope that it will be useful,
-// but WITHOUT ANY WARRANTY; without even the implied warranty of
-// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-// GNU General Public License for more details.
-//
-// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
-@NonCPS
-
-// Using a version specifier library, use 'current' branch. The underscore (_)
-// is not a typo! You need this underscore if the line immediately after the
-// @Library annotation is not an import statement!
-@Library('vyos-build@current')_
-
-def pkgList = [
- ['name': 'fastnetmon-debian-salsa',
- 'scmCommit': 'debian/1.2.2-1',
- 'scmUrl': 'https://salsa.debian.org/debian/fastnetmon.git',
- 'buildCmd': '/bin/true'],
- ['name': 'fastnetmon',
- 'scmCommit': 'v1.2.2',
- 'scmUrl': 'https://github.com/pavel-odintsov/fastnetmon.git',
- 'buildCmd': 'cd ..; ./build.sh'],
-]
-
-// Start package build using library function from https://github.com/vyos/vyos-build
-buildPackage('fastnetmon', pkgList, null, false, "**/packages/fastnetmon/*")
diff --git a/packages/fastnetmon/build.sh b/packages/fastnetmon/build.sh
deleted file mode 100755
index 1230e650..00000000
--- a/packages/fastnetmon/build.sh
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-CWD=$(pwd)
-set -e
-
-SRC=fastnetmon
-if [ ! -d ${SRC} ]; then
- echo "Source directory does not exists, please 'git clone'"
- exit 1
-fi
-
-tar -czf fastnetmon_$(head -n 1 fastnetmon-debian-salsa/debian/changelog|awk '{print $2}'|sed 's/[()]//g' | sed -E 's/(\-[0-9]+)?$//').orig.tar.gz fastnetmon
-
-cd ${SRC}
-rm -rf debian && cp -a ../fastnetmon-debian-salsa/debian/ .
-
-dpkg-buildpackage -uc -us -tc -b -d