summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorScott Moser <smoser@brickies.net>2016-08-23 16:48:37 -0400
committerScott Moser <smoser@brickies.net>2016-08-23 16:48:37 -0400
commit7b0efb97c3667d4d1335e384433877a13e065380 (patch)
treee854ffa174128a5539af979707f1c5f850437d58 /debian/rules
parent74fe2d2c661d70e5ec93ebde036d927c0f9ed15c (diff)
downloadvyos-cloud-init-7b0efb97c3667d4d1335e384433877a13e065380.tar.gz
vyos-cloud-init-7b0efb97c3667d4d1335e384433877a13e065380.zip
Import version 0.7.7~bzr1154-0ubuntu1
Imported using git-dsc-commit.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..d83f102d
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+INIT_SYSTEM ?= upstart,systemd
+export PYBUILD_INSTALL_ARGS=--init-system=$(INIT_SYSTEM)
+
+%:
+ dh $@ --with python3,systemd --buildsystem pybuild
+
+override_dh_auto_test:
+ # Because setup tools didn't copy data...
+ [ ! -d .pybuild/pythonX.Y_?.?/build/tests ] || cp -r tests/data .pybuild/pythonX.Y_?.?/build/tests
+ # We set http_proxy because of httpretty issue 122 trunk has worked
+ # around that but to support cloud-init that has not.
+ http_proxy= dh_auto_test -- --test-nose
+
+override_dh_systemd_start:
+ dh_systemd_start --no-restart-on-upgrade --no-start
+