summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorScott Moser <smoser@ubuntu.com>2018-06-04 09:56:59 -0400
committerScott Moser <smoser@ubuntu.com>2018-06-04 10:15:36 -0400
commit525a9e8f52a050bacea4b1e54eaf72d2fa093849 (patch)
tree370e081c7961b5826fc9796877fd32c697cce0bb /debian
parentb7cca5fae8fe5b6fd557a31d6bfdfbfb65cce43f (diff)
downloadvyos-cloud-init-525a9e8f52a050bacea4b1e54eaf72d2fa093849.tar.gz
vyos-cloud-init-525a9e8f52a050bacea4b1e54eaf72d2fa093849.zip
debian/rules: update version.version_string to contain packaged version.
This is the debian packaging portion of upstream commit 5446c7881604. The end result is that we will see the debian package and full upstream version wherever cloud-init reports its version. LP: #1770712 (cherry picked from commit 672326d48d759f9477f5cbb9d8088ceeac96aa23)
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules2
1 files changed, 2 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 72754aab..c5b18ebb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,7 @@
#!/usr/bin/make -f
INIT_SYSTEM ?= upstart,systemd
export PYBUILD_INSTALL_ARGS=--init-system=$(INIT_SYSTEM)
+DEB_VERSION := $(shell dpkg-parsechangelog --show-field=Version)
%:
dh $@ --with python3,systemd --buildsystem pybuild
@@ -21,3 +22,4 @@ override_dh_auto_install:
install -D ./tools/Z99-cloud-locale-test.sh debian/cloud-init/etc/profile.d/Z99-cloud-locale-test.sh
install -D ./tools/Z99-cloudinit-warnings.sh debian/cloud-init/etc/profile.d/Z99-cloudinit-warnings.sh
install -m 0644 -D debian/apport-launcher.py debian/cloud-init/usr/share/apport/package-hooks/cloud-init.py
+ flist=$$(find $(CURDIR)/debian/ -type f -name version.py) && sed -i 's,@@PACKAGED_VERSION@@,$(DEB_VERSION),' $${flist:-did-not-find-version-py-for-replacement}