summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChuck Short <zulcss@ubuntu.com>2009-03-22 23:39:45 +0000
committerBazaar Package Importer <jamesw@ubuntu.com>2009-03-22 23:39:45 +0000
commite606fe4288e31eeef1d90a62773bdc946e650381 (patch)
tree901e260670c2fa304239a687904ad56333dd15e3 /debian
parent58f82c2220b3137c97a377b01da04a14c64b0a1d (diff)
downloadvyos-cloud-init-e606fe4288e31eeef1d90a62773bdc946e650381.tar.gz
vyos-cloud-init-e606fe4288e31eeef1d90a62773bdc946e650381.zip
* Set the configuration file to jaunty.
* ec2-fetch-credentials: Fix typo. * ec2-set-defaults.py: - Remove timezone change when booting the instance. - Redirect output to /dev/null. * ec2-set-apt-sources.py: - Run apt-get update after the /etc/apt/sources.list and redirect the output to /dev/null. * rightscale-init: Updated rightscale-init
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog14
-rw-r--r--debian/ec2-config.cfg2
-rw-r--r--debian/ec2-init.rightscale-init.init24
-rwxr-xr-xdebian/rules3
4 files changed, 24 insertions, 19 deletions
diff --git a/debian/changelog b/debian/changelog
index 814c6a7b..349e4add 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+ec2-init (0.3.3ubuntu6) jaunty; urgency=low
+
+ * Set the configuration file to jaunty.
+ * ec2-fetch-credentials: Fix typo.
+ * ec2-set-defaults.py:
+ - Remove timezone change when booting the instance.
+ - Redirect output to /dev/null.
+ * ec2-set-apt-sources.py:
+ - Run apt-get update after the /etc/apt/sources.list and
+ redirect the output to /dev/null.
+ * rightscale-init: Updated rightscale-init
+
+ -- Chuck Short <zulcss@ubuntu.com> Thu, 19 Mar 2009 20:52:59 -0400
+
ec2-init (0.3.3ubuntu5) jaunty; urgency=low
* debian/ec2-config.cfg:
diff --git a/debian/ec2-config.cfg b/debian/ec2-config.cfg
index cd38d598..ebf5eb69 100644
--- a/debian/ec2-config.cfg
+++ b/debian/ec2-config.cfg
@@ -1,3 +1,3 @@
user="ubuntu"
-distro="intrepid"
+distro="jaunty"
DISABLE_ROOT="1"
diff --git a/debian/ec2-init.rightscale-init.init b/debian/ec2-init.rightscale-init.init
index 4a1c52af..10ba39d3 100644
--- a/debian/ec2-init.rightscale-init.init
+++ b/debian/ec2-init.rightscale-init.init
@@ -1,16 +1,7 @@
-#!/bin/sh
-
-### BEGIN INIT INFO
-# Provides: rightscale
-# Required-Start:
-# Required-Stop:
-# Default-Start: 2 3 4 5
-# Default-Stop: 1
-# Sort-Description: Setup Righscale
-
+#!/bin/bash
+#
# This script will configure an Ubuntu server for use with RightScale
-
-set -e
+#
start() {
## First check to see if we were launched through RightScale. Exit and remove if not...
@@ -32,7 +23,7 @@ start() {
echo "Installing necessary packages..."
export DEBIAN_FRONTEND=NONINTERACTIVE
apt-get update
- apt-get install -y binutils sysv-rc-conf unzip ruby1.8-dev autoconf automake libtool logrotate rsync openssl ca-certificates
+ apt-get install -y binutils ruby1.8 sysv-rc-conf unzip ruby1.8-dev build-essential autoconf automake libtool logrotate rsync openssl ca-certificates libopenssl-ruby1.8
## Add rightscale customizations
echo "Installing RightScale"
@@ -90,10 +81,9 @@ stop() {
}
remove() {
- my_name=`basename $0`
- init_script_name=${my_name:3}
- update-rc.d -f $init_script_name remove
- rm -f /etc/init.d/$init_script_name
+ my_name=`readlink -e $0`
+ update-rc.d -f `basename $my_name` remove
+ rm -f $my_name
}
diff --git a/debian/rules b/debian/rules
index 4d362f5b..646b11f5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,4 +13,5 @@ build/ec2-init::
install -m 755 ec2-set-hostname.py debian/tmp/usr/sbin/ec2-set-hostname
install -m 755 ec2-set-apt-sources.py debian/tmp/usr/sbin/ec2-set-apt-sources
install -m755 ec2-get-info.py debian/tmp/usr/sbin/ec2-get-info
- dh_installinit -p ec2-init --name rightscale-init -- defaults 20 21
+ install -m755 ec2-set-defaults.py debian/tmp/usr/sbin/ec2-set-defaults
+ dh_installiniti -p ec2-init --name rightscale-init -- defaults 99 09