summaryrefslogtreecommitdiff
path: root/packages/debian/rules.in
diff options
context:
space:
mode:
authorScott Moser <smoser@brickies.net>2016-08-05 15:51:34 -0400
committerScott Moser <smoser@brickies.net>2016-08-05 16:53:53 -0400
commit42bed116b411eb25ebd8368b2b4ed6c56ffd85e7 (patch)
tree60af1c21adda46878ccf9a0c6ab1b3640fa61a4a /packages/debian/rules.in
parent10f82bd474c5bc91b330beccd883da06b0014a99 (diff)
downloadvyos-cloud-init-42bed116b411eb25ebd8368b2b4ed6c56ffd85e7.tar.gz
vyos-cloud-init-42bed116b411eb25ebd8368b2b4ed6c56ffd85e7.zip
drop modification of version during make-tarball, tools changes.
Modification of the tarball became problematic, as it meant that any tool extracting source would find the orig source tarball different. I found this unusable when trying to use 'gbp buildpackage'. Other changes here are to better support using python3 or python2 for the build. Makefile will try to call the right python version and can be told which python to use. read-version: by adding 'tiny_p' and avoiding the import of cloudinit.util, we need less dependencies to run this.
Diffstat (limited to 'packages/debian/rules.in')
-rwxr-xr-xpackages/debian/rules.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/packages/debian/rules.in b/packages/debian/rules.in
index cf2dd405..9b004357 100755
--- a/packages/debian/rules.in
+++ b/packages/debian/rules.in
@@ -14,7 +14,7 @@ override_dh_install:
override_dh_auto_test:
ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
- http_proxy= make PYVER=${pyver} check
+ http_proxy= make PYVER=python${pyver} check
else
@echo check disabled by DEB_BUILD_OPTIONS=$(DEB_BUILD_OPTIONS)
endif