summaryrefslogtreecommitdiff
path: root/packages/debian/rules
diff options
context:
space:
mode:
authorJoshua Harlow <harlowja@yahoo-inc.com>2012-07-09 16:08:22 -0400
committerScott Moser <smoser@ubuntu.com>2012-07-09 16:08:22 -0400
commit0ed44de3afa63c296040bcf7302bac35b8cafc21 (patch)
treea2eae957491ab27c282c651fbd1d73701a93ee5f /packages/debian/rules
parenta7e13e1f540019170de0f4fb0e008b703226df77 (diff)
downloadvyos-cloud-init-0ed44de3afa63c296040bcf7302bac35b8cafc21.tar.gz
vyos-cloud-init-0ed44de3afa63c296040bcf7302bac35b8cafc21.zip
Get the debian package building working again.
Also, remove the pre-processing of debian/rules. instead use an environment variable. To build with sysvinit: $ INIT_SYSTEM=sysvinit ./packages/bddeb Note, debuild does complain with several errors on sysvinit building at the moment. Primarily about package installing into /etc/init.d.
Diffstat (limited to 'packages/debian/rules')
-rwxr-xr-xpackages/debian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/packages/debian/rules b/packages/debian/rules
index 87cd6538..7623ac9d 100755
--- a/packages/debian/rules
+++ b/packages/debian/rules
@@ -1,13 +1,14 @@
#!/usr/bin/make -f
DEB_PYTHON2_MODULE_PACKAGES = cloud-init
+INIT_SYSTEM ?= upstart
binary-install/cloud-init::cloud-init-fixups
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/python-distutils.mk
-DEB_PYTHON_INSTALL_ARGS_ALL += --init-system={{init_sys}}
+DEB_PYTHON_INSTALL_ARGS_ALL += --init-system=$(INIT_SYSTEM)
DEB_DH_INSTALL_SOURCEDIR := debian/tmp