summaryrefslogtreecommitdiff
path: root/packages/debian/rules
diff options
context:
space:
mode:
authorJoshua Harlow <harlowja@yahoo-inc.com>2012-06-25 23:56:15 -0700
committerJoshua Harlow <harlowja@yahoo-inc.com>2012-06-25 23:56:15 -0700
commit86d7dfa8dae0b53866462ce8e737309a40436402 (patch)
tree87dc3da284fe0c886ad5de53689c0d3996439d44 /packages/debian/rules
parentc9fa666745567d7e3c9d55a83dfedad40e13ea9a (diff)
downloadvyos-cloud-init-86d7dfa8dae0b53866462ce8e737309a40436402.tar.gz
vyos-cloud-init-86d7dfa8dae0b53866462ce8e737309a40436402.zip
1. Change these to be templates where possible.
2. Rename to be a debian subdir, matching the redhat subdir.
Diffstat (limited to 'packages/debian/rules')
-rwxr-xr-xpackages/debian/rules27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/debian/rules b/packages/debian/rules
new file mode 100755
index 00000000..a907b594
--- /dev/null
+++ b/packages/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+
+DEB_PYTHON2_MODULE_PACKAGES = cloud-init
+
+binary-install/cloud-init::cloud-init-fixups
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/python-distutils.mk
+
+DEB_DH_INSTALL_SOURCEDIR := debian/tmp
+
+cloud-init-fixups:
+ install -d $(DEB_DESTDIR)/etc/rsyslog.d
+ cp tools/21-cloudinit.conf $(DEB_DESTDIR)/etc/rsyslog.d/21-cloudinit.conf
+
+# You only need to run this immediately after checking out the package from
+# revision control.
+# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=572204
+quilt-setup:
+ @[ ! -d .pc ] || { echo ".pc exists. remove it and re-run to start fresh"; exit 1; }
+ set -e; for patch in $$(quilt series | tac); do \
+ patch -p1 -R --no-backup-if-mismatch <"debian/patches/$$patch"; \
+ done
+ quilt push -a
+
+.PHONY: quilt-setup
+