summaryrefslogtreecommitdiff
path: root/packages/debian
diff options
context:
space:
mode:
authorScott Moser <smoser@ubuntu.com>2015-02-10 20:32:32 +0000
committerScott Moser <smoser@ubuntu.com>2015-02-10 20:32:32 +0000
commita4a6702758cf60ecb8742d78e576733dbbdbb9a0 (patch)
treeb5f23eff4f9c7e87fe2b09cdbe1d1b38aa518929 /packages/debian
parent888db3e6bb9076973d2f6a73e0c4f691caa89603 (diff)
downloadvyos-cloud-init-a4a6702758cf60ecb8742d78e576733dbbdbb9a0.tar.gz
vyos-cloud-init-a4a6702758cf60ecb8742d78e576733dbbdbb9a0.zip
make bddeb work with python3 or python2
painful, and not perfect, but at this point the output builds on a vivid system python2 (bddeb --python2) or python3. * remove use of cheetah by bddeb in favor of builtin renderer * add '--python2' flag to bddeb and knowledge of python 2 and python3 package names. * read-dependencies can now read test-requirements also. * differenciate from build-requirements and runtime requirements.
Diffstat (limited to 'packages/debian')
-rw-r--r--packages/debian/changelog.in2
-rw-r--r--packages/debian/control.in29
-rwxr-xr-xpackages/debian/rules.in (renamed from packages/debian/rules)8
3 files changed, 16 insertions, 23 deletions
diff --git a/packages/debian/changelog.in b/packages/debian/changelog.in
index e3e94f54..c9affe47 100644
--- a/packages/debian/changelog.in
+++ b/packages/debian/changelog.in
@@ -1,4 +1,4 @@
-## This is a cheetah template
+## template:basic
cloud-init (${version}~bzr${revision}-1) UNRELEASED; urgency=low
* build
diff --git a/packages/debian/control.in b/packages/debian/control.in
index 9207e5f4..bd6e3867 100644
--- a/packages/debian/control.in
+++ b/packages/debian/control.in
@@ -1,4 +1,4 @@
-## This is a cheetah template
+## template:basic
Source: cloud-init
Section: admin
Priority: optional
@@ -6,31 +6,22 @@ Maintainer: Scott Moser <smoser@ubuntu.com>
Build-Depends: debhelper (>= 9),
dh-python,
dh-systemd,
- python (>= 2.6.6-3~),
- python-nose,
pyflakes,
- python-setuptools,
- python-selinux,
- python-cheetah,
- python-mocker,
- python-httpretty,
-#for $r in $requires
- ${r},
-#end for
+ ${python},
+ ${test_requires},
+ ${requires}
XS-Python-Version: all
-Standards-Version: 3.9.3
+Standards-Version: 3.9.6
Package: cloud-init
Architecture: all
Depends: procps,
- python,
-#for $r in $requires
- ${r},
-#end for
- python-software-properties | software-properties-common,
- \${misc:Depends},
+ ${python},
+ ${requires},
+ software-properties-common,
+ ${misc:Depends},
Recommends: sudo
-XB-Python-Version: \${python:Versions}
+XB-Python-Version: ${python:Versions}
Description: Init scripts for cloud instances
Cloud instances need special scripts to run during initialisation
to retrieve and install ssh keys and to let the user run various scripts.
diff --git a/packages/debian/rules b/packages/debian/rules.in
index 9e0c5ddb..bb2e1d5c 100755
--- a/packages/debian/rules
+++ b/packages/debian/rules.in
@@ -1,10 +1,12 @@
+## template:basic
#!/usr/bin/make -f
INIT_SYSTEM ?= upstart,systemd
+PYVER ?= python${pyver}
export PYBUILD_INSTALL_ARGS=--init-system=$(INIT_SYSTEM)
%:
- dh $@ --with python2,systemd --buildsystem pybuild
+ dh $@ --with $(PYVER),systemd --buildsystem pybuild
override_dh_install:
dh_install
@@ -12,6 +14,6 @@ override_dh_install:
cp tools/21-cloudinit.conf debian/cloud-init/etc/rsyslog.d/21-cloudinit.conf
override_dh_auto_test:
- # Becuase setup tools didn't copy data...
- cp -r tests/data .pybuild/pythonX.Y_2.7/build/tests
+ # Because setup tools didn't copy data...
+ [ ! -d .pybuild/pythonX.Y_?.?/build/tests ] || cp -r tests/data .pybuild/pythonX.Y_?.?/build/tests
http_proxy= dh_auto_test -- --test-nose