summaryrefslogtreecommitdiff
path: root/packages/debian
diff options
context:
space:
mode:
authorDimitri John Ledkov <dimitri.ledkov@canonical.com>2014-07-23 15:47:16 +0100
committerDimitri John Ledkov <dimitri.ledkov@canonical.com>2014-07-23 15:47:16 +0100
commita04baf85a8eea4eb02168429aa6bfaaeb2effb42 (patch)
tree1d9d8eb3396bc8c84322e69878d8f60cc063fd21 /packages/debian
parente9f9c1e1cd47786b93491fd0f73467674c88828e (diff)
downloadvyos-cloud-init-a04baf85a8eea4eb02168429aa6bfaaeb2effb42.tar.gz
vyos-cloud-init-a04baf85a8eea4eb02168429aa6bfaaeb2effb42.zip
Modernise packaging, and allow multiple init system installation (based on smoser pastebins).
Diffstat (limited to 'packages/debian')
-rw-r--r--packages/debian/compat2
-rw-r--r--packages/debian/control.in13
-rw-r--r--packages/debian/pycompat1
-rwxr-xr-xpackages/debian/rules20
4 files changed, 17 insertions, 19 deletions
diff --git a/packages/debian/compat b/packages/debian/compat
index 7ed6ff82..ec635144 100644
--- a/packages/debian/compat
+++ b/packages/debian/compat
@@ -1 +1 @@
-5
+9
diff --git a/packages/debian/control.in b/packages/debian/control.in
index 7e42b94b..6e383dcc 100644
--- a/packages/debian/control.in
+++ b/packages/debian/control.in
@@ -1,10 +1,11 @@
## This is a cheetah template
Source: cloud-init
Section: admin
-Priority: extra
+Priority: optional
Maintainer: Scott Moser <smoser@ubuntu.com>
-Build-Depends: cdbs,
- debhelper (>= 5.0.38),
+Build-Depends: debhelper (>= 9),
+ dh-python,
+ dh-systemd,
python (>= 2.6.6-3~),
python-nose,
pyflakes,
@@ -12,7 +13,11 @@ Build-Depends: cdbs,
python-setuptools,
python-cheetah,
python-mocker,
- python-setuptools
+ python-setuptools,
+ python-httpretty,
+#for $r in $requires
+ ${r},
+#end for
XS-Python-Version: all
Standards-Version: 3.9.3
diff --git a/packages/debian/pycompat b/packages/debian/pycompat
deleted file mode 100644
index 0cfbf088..00000000
--- a/packages/debian/pycompat
+++ /dev/null
@@ -1 +0,0 @@
-2
diff --git a/packages/debian/rules b/packages/debian/rules
index 7623ac9d..c1344e60 100755
--- a/packages/debian/rules
+++ b/packages/debian/rules
@@ -1,18 +1,12 @@
#!/usr/bin/make -f
DEB_PYTHON2_MODULE_PACKAGES = cloud-init
-INIT_SYSTEM ?= upstart
+INIT_SYSTEM ?= upstart,systemd
-binary-install/cloud-init::cloud-init-fixups
+%:
+ dh $@ --with python2,systemd --build-system pybuild
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/python-distutils.mk
-
-DEB_PYTHON_INSTALL_ARGS_ALL += --init-system=$(INIT_SYSTEM)
-
-DEB_DH_INSTALL_SOURCEDIR := debian/tmp
-
-cloud-init-fixups:
- install -d $(DEB_DESTDIR)/etc/rsyslog.d
- cp tools/21-cloudinit.conf $(DEB_DESTDIR)/etc/rsyslog.d/21-cloudinit.conf
-
+override_dh_install:
+ dh_install
+ install -d debian/cloud-init/etc/rsyslog.d
+ cp tools/21-cloudinit.conf debian/cloud-init/etc/rsyslog.d/21-cloudinit.conf