summaryrefslogtreecommitdiff
path: root/packages/redhat/cloud-init.spec.in
diff options
context:
space:
mode:
authorJoshua Harlow <harlowja@yahoo-inc.com>2012-09-28 14:21:02 -0700
committerJoshua Harlow <harlowja@yahoo-inc.com>2012-09-28 14:21:02 -0700
commit72fc1f762e5c5df563380e9ed90bfaba131e811b (patch)
tree2420fd4938324bedc739ec4e1573a4211a12a02f /packages/redhat/cloud-init.spec.in
parent5233b6edb70702476463b47c06cb02b3c7f74c51 (diff)
parentd285a0463b6d16487eb5859373ccfd27eaec8b90 (diff)
downloadvyos-cloud-init-72fc1f762e5c5df563380e9ed90bfaba131e811b.tar.gz
vyos-cloud-init-72fc1f762e5c5df563380e9ed90bfaba131e811b.zip
Sync with head and fix conflicts.
Diffstat (limited to 'packages/redhat/cloud-init.spec.in')
-rw-r--r--packages/redhat/cloud-init.spec.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/redhat/cloud-init.spec.in b/packages/redhat/cloud-init.spec.in
index 35b27beb..12f0b144 100644
--- a/packages/redhat/cloud-init.spec.in
+++ b/packages/redhat/cloud-init.spec.in
@@ -5,6 +5,10 @@
# Or: http://fedoraproject.org/wiki/Packaging:ScriptletSnippets
# Or: http://www.rpm.org/max-rpm/ch-rpm-inside.html
+#for $d in $defines
+%define ${d}
+#end for
+
Name: cloud-init
Version: ${version}
Release: ${release}%{?dist}
@@ -36,6 +40,13 @@ Requires: shadow-utils
Requires: ${r}
#end for
+# Custom patches
+#set $size = 0
+#for $p in $patches
+Patch${size}: $p
+#set $size += 1
+#end for
+
#if $sysvinit
Requires(post): chkconfig
Requires(postun): initscripts
@@ -58,6 +69,13 @@ ssh keys and to let the user run various scripts.
%prep
%setup -q -n %{name}-%{version}~${release}
+# Custom patches activation
+#set $size = 0
+#for $p in $patches
+%patch${size} -p1
+#set $size += 1
+#end for
+
%build
%{__python} setup.py build