summaryrefslogtreecommitdiff
path: root/packages/redhat
diff options
context:
space:
mode:
authorJoshua Harlow <harlowja@yahoo-inc.com>2012-06-25 23:55:40 -0700
committerJoshua Harlow <harlowja@yahoo-inc.com>2012-06-25 23:55:40 -0700
commit838a65e9c988cecb281c99a8de89c921fdfc9c61 (patch)
tree19be3352ab83ef1aeca6e9b6421db3a7f08e28be /packages/redhat
parentcb49d6d4a1b5699b5e0afca1ac15d7225a8728a4 (diff)
downloadvyos-cloud-init-838a65e9c988cecb281c99a8de89c921fdfc9c61.tar.gz
vyos-cloud-init-838a65e9c988cecb281c99a8de89c921fdfc9c61.zip
Move redhat spec file templates to this directory
Diffstat (limited to 'packages/redhat')
-rw-r--r--packages/redhat/cloud-init.spec70
1 files changed, 70 insertions, 0 deletions
diff --git a/packages/redhat/cloud-init.spec b/packages/redhat/cloud-init.spec
new file mode 100644
index 00000000..f0c874ee
--- /dev/null
+++ b/packages/redhat/cloud-init.spec
@@ -0,0 +1,70 @@
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
+
+Name: cloud-init
+Version: {{version}}
+Release: {{release}}%{?dist}
+Summary: Cloud instance init scripts
+
+Group: System Environment/Base
+License: GPLv3
+URL: http://launchpad.net/cloud-init
+
+Source0: {{archive_name}}
+
+BuildArch: noarch
+
+BuildRoot: %{_tmppath}
+
+
+{{for r in bd_requires}}
+BuildRequires: {{r}}
+{{endfor}}
+
+# Install requirements
+{{for r in requires}}
+Requires: {{r}}
+{{endfor}}
+
+%description
+Cloud-init is a set of init scripts for cloud instances. Cloud instances
+need special scripts to run during initialization to retrieve and install
+ssh keys and to let the user run various scripts.
+
+
+%prep
+%setup -q -n %{name}-%{version}-{{revno}}
+
+%build
+%{__python} setup.py build
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+
+# Docs
+{{for r in docs}}
+%doc {{r}}
+{{endfor}}
+
+# Configs
+{{for r in configs}}
+%config(noreplace) %{_sysconfdir}/{{r}}
+{{endfor}}
+
+# Other files
+{{for r in files}}
+{{r}}
+{{endfor}}
+
+# Python sitelib
+%{python_sitelib}/*
+
+%changelog
+
+{{changelog}}