summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJoshua Harlow <harlowja@yahoo-inc.com>2012-06-20 16:34:09 -0700
committerJoshua Harlow <harlowja@yahoo-inc.com>2012-06-20 16:34:09 -0700
commit00b19244b9e3a88ff6252494e43268ba692815a6 (patch)
tree905f08825165df6d1e1bce9ecb5f5b292a26f482 /setup.py
parentd464a95b93a3956ba09edba91d651c9493bd66ca (diff)
downloadvyos-cloud-init-00b19244b9e3a88ff6252494e43268ba692815a6.tar.gz
vyos-cloud-init-00b19244b9e3a88ff6252494e43268ba692815a6.zip
1. Add a comment that the upstart dir should probably be put elsewhere sometime (in a distro specific build?)
since not all distros fully support upstart that is in config here or even have upstart in general at all (for various reasons) 2. Found out that we really do need to specify these 2 packages due to the following a. The cloudinit root needs to be a package (pretty obvious) b. Not so obvious is the cloudinit.conf also needs to be a package so that its modules can be directly imported without referring to the module name.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 9ee58b9a..d2e022f0 100755
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,6 @@ import os
import re
from distutils.core import setup
-from setuptools import find_packages
def is_f(p):
@@ -69,13 +68,17 @@ setup(name='cloud-init',
author='Scott Moser',
author_email='scott.moser@canonical.com',
url='http://launchpad.net/cloud-init/',
- packages=find_packages(),
+ # This second package referencing cloudinit.conf.*
+ # makes the config modules accessible to the whole
+ # import system...
+ packages=['cloudinit', 'cloudinit.conf'],
scripts=['bin/cloud-init',
'tools/cloud-init-per',
],
data_files=[('/etc/cloud', glob('config/*.cfg')),
('/etc/cloud/cloud.cfg.d', glob('config/cloud.cfg.d/*')),
('/etc/cloud/templates', glob('templates/*')),
+ # Only really need for upstart based systems
('/etc/init', glob('upstart/*.conf')),
('/usr/share/cloud-init', []),
('/usr/lib/cloud-init',