diff options
author | Barry Warsaw <barry@python.org> | 2015-01-21 15:14:24 -0500 |
---|---|---|
committer | Barry Warsaw <barry@python.org> | 2015-01-21 15:14:24 -0500 |
commit | ee4a174e2e3b3268ef95485b99d81edea1ca3458 (patch) | |
tree | ed6ece63e85aea7782227159f4cf0e57c4b1a99e /setup.py | |
parent | 8d453d2a4da4492857a4487b14fe7b11a014115b (diff) | |
download | vyos-cloud-init-ee4a174e2e3b3268ef95485b99d81edea1ca3458.tar.gz vyos-cloud-init-ee4a174e2e3b3268ef95485b99d81edea1ca3458.zip |
* Added a simple tox.ini file
* Use universal_newlines in setup.py so it will work properly in Python 3.
* Fix a pyflakes complaint in setup.py
* Add a simple MANIFEST.in
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 7 |
1 files changed, 4 insertions, 3 deletions
@@ -45,7 +45,8 @@ def tiny_p(cmd, capture=True): stdout = None stderr = None sp = subprocess.Popen(cmd, stdout=stdout, - stderr=stderr, stdin=None) + stderr=stderr, stdin=None, + universal_newlines=True) (out, err) = sp.communicate() ret = sp.returncode if ret not in [0]: @@ -144,9 +145,9 @@ class InitsysInstallData(install): raise DistutilsArgError( "Invalid --init-system: %s" % (','.join(bad))) - for sys in self.init_system: + for system in self.init_system: self.distribution.data_files.append( - (INITSYS_ROOTS[sys], INITSYS_FILES[sys])) + (INITSYS_ROOTS[system], INITSYS_FILES[system])) # Force that command to reinitalize (with new file list) self.distribution.reinitialize_command('install_data', True) |