summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSoren Hansen <soren@canonical.com>2009-06-27 19:46:17 +0200
committerSoren Hansen <soren@canonical.com>2009-06-27 19:46:17 +0200
commit14c431c2d1c2eeff3a9a104beb937073ad426679 (patch)
tree8998e78a0827de4f42bd577ad0d4a1085d4506dd /setup.py
parentb098228ab03003218b894855142dec9a8f406cfb (diff)
downloadvyos-cloud-init-14c431c2d1c2eeff3a9a104beb937073ad426679.tar.gz
vyos-cloud-init-14c431c2d1c2eeff3a9a104beb937073ad426679.zip
Update license to GPLv3 (dropping the "or later" bit).
Update copyright years. Add copyright and license information to setup.py. Add myself as author of the relevant files.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py19
1 files changed, 19 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 851e559f..a957f8ae 100755
--- a/setup.py
+++ b/setup.py
@@ -1,3 +1,22 @@
+#!/usr/bin/python
+#
+# Distutils magic for ec2-init
+# Copyright (C) 2009 Canonical Ltd.
+#
+# Author: Soren Hansen <soren@canonical.com>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 3, as
+# published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
from distutils.core import setup
from glob import glob
import os.path