diff options
author | Joshua Harlow <harlowja@yahoo-inc.com> | 2012-07-02 15:40:51 -0700 |
---|---|---|
committer | Joshua Harlow <harlowja@yahoo-inc.com> | 2012-07-02 15:40:51 -0700 |
commit | 37aa678a39d8ac568351ce754d202c1069034d1c (patch) | |
tree | 873d70069f9d3a7a2eb96c12941c0a525eff1b61 /setup.py | |
parent | 879946c26f005f5ae5c2bbdd537beb295d7f4773 (diff) | |
download | vyos-cloud-init-37aa678a39d8ac568351ce754d202c1069034d1c.tar.gz vyos-cloud-init-37aa678a39d8ac568351ce754d202c1069034d1c.zip |
1. Fixup the setup.py to not include custom startup scripts, let the packaging solutions handle these
2. Get the cloud-init specfile working for the init.d case (with the right postun and post and install sections)
a. It works!!!
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 8 |
1 files changed, 0 insertions, 8 deletions
@@ -76,20 +76,12 @@ setuptools.setup(name='cloud-init', data_files=[('/etc/cloud', glob('config/*.cfg')), ('/etc/cloud/cloud.cfg.d', glob('config/cloud.cfg.d/*')), ('/etc/cloud/templates', glob('templates/*')), - # Only really need for upstart based systems - ('/etc/init', glob('upstart/*.conf')), - # Only really need for systemd based systems - ('/etc/systemd/system', glob('systemd/*.service')), - # Only really need for init.d based system - ('/etc/init.d', glob('initd/*')), ('/usr/share/cloud-init', []), ('/usr/lib/cloud-init', ['tools/uncloud-init', 'tools/write-ssh-key-fingerprints']), ('/usr/share/doc/cloud-init', filter(is_f, glob('doc/*'))), ('/usr/share/doc/cloud-init/examples', filter(is_f, glob('doc/examples/*'))), ('/usr/share/doc/cloud-init/examples/seed', filter(is_f, glob('doc/examples/seed/*'))), - # ?? - # ('/etc/profile.d', ['tools/Z99-cloud-locale-test.sh']), ], install_requires=read_requires(), ) |