summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSoren Hansen <soren@canonical.com>2009-08-10 21:34:47 +0200
committerSoren Hansen <soren@canonical.com>2009-08-10 21:34:47 +0200
commit1f33a10388e1ac4079d17e9b836dfb4ab7730fec (patch)
tree4260d5f37c0c3b45eba8728d48f86dbe40965461 /setup.py
parent1cac841c3365f31a6021a63407f2001cfc69c04d (diff)
downloadvyos-cloud-init-1f33a10388e1ac4079d17e9b836dfb4ab7730fec.tar.gz
vyos-cloud-init-1f33a10388e1ac4079d17e9b836dfb4ab7730fec.zip
Move ec2 init script from debian/ out into top-level.
Install init-script using distutils. Add -o to dh_installinit call to let it find the init script.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index dacdd509..e199eb1b 100755
--- a/setup.py
+++ b/setup.py
@@ -36,5 +36,6 @@ setup(name='EC2-init',
'ec2-set-hostname.py',
'ec2-wait-for-meta-data-service.py'],
data_files=[('/etc/ec2-init', ['debian/ec2-config.cfg']),
- ('/etc/ec2-init/templates', glob('templates/*'))],
+ ('/etc/ec2-init/templates', glob('templates/*')),
+ ('/etc/init.d', ['ec2-init'])],
)